Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

PHP Changed after Installation


Recommended Posts

Due to a server crash, I decided to upgrade to oscommerce-2.2rc2a for one of my clients. I treated it as a new install since all data was lost. After doing the auto-install, my .htaccess file ceased to parse PHP in an HTML page. It actually cause my main page to go blank.


.htaccess file when main page went blank


Options Indexes FollowSymLinks ExecCGI Includes

AddType application/x-httpd-php .html .php4 .php .htm .php3 .inc
ErrorDocument 404 /404.html

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $
# This is used with Apache WebServers
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
# Example:
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

#<IfModule mod_setenvif.c>
#  <IfDefine SSL>
#	SetEnvIf User-Agent ".*MSIE.*" \
#			 nokeepalive ssl-unclean-shutdown \
#			 downgrade-1.0 force-response-1.0
#  </IfDefine>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter

# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)

# php_value session.use_trans_sid 0
# php_value register_globals 1


The current .htaccess file has been modified to at least show the page. I commented out "AddType application/x-httpd-php .html .php4 .php .htm .php3 .inc". This should allow someone to see the source code right now too. The site is:


Rapicom Main Page (apache server)


I've tried to do the following with no success/solution:

  • Search this forum (difficult with the keywords I needing to use)
  • Change my .html to a .php (still won't display properly)
  • Tried different .htaccess snippets to parse PHP


I know this is a bit off topic, but I certainly can't be the only one who's had this issue.


Thanks for any help!



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...