Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

OSC Move to Root Question


Recommended Posts

Okay... I installed my OSCommerce site in a directory called oscommercetest with the plesk tool on a 1and1 VPS. Worked like a charm. I added my skin, and everything worked fine. I decided to move the application to the root and leave the other for code change testing. I made appropriate changes to both configure.php and everything worked except I kept getting product not found errors when I clicked on a product. It seemed like the GET_HTTP_VARS call for products_id was returning '0' and the app was basically ignoring querystring values.


I did some research and looked into the issue. Some suggested adding php.ini with the following


register_globals = On

register_long_arrays = On


I created php.ini, put in the root and restarted the web service, but that didn't do it. maybe file permissions? but I looked and the working version in my oscommercetest folder did not have a php.ini either. I found a workaround/hack in application_top that manually populates the HTTP_GET_VARS array


foreach($_GET as $key=>$value) 	$HTTP_GET_VARS[$key]=$value;foreach($_POST as $key=>$value) 	$HTTP_POST_VARS[$key]=$value;


and that seems to work, but I dont understand what the real problem is/was. Any thoughts on where to look? As I said before, it works fine in the original install directory. I'd rather not modify the code with a workaround. Any help is appreciated. Thanks!



Link to comment
Share on other sites

If it works in your test folder but not in the root double check your configure.php files and your .htaccess file.



Hmmm... I must have copied the offending change back into the original test folder because now it is doing the same thing. I will just add those lines to the application_top page and move to the next problem.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...