Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

FATAL ERROR: register_globals is disabled in php.ini, please enable it!


Guest

Recommended Posts

Hi Guys where would i find this file?

 

TIA

 

Richard

On your server, not in your shop.

 

There is a register globals fix in the add ons area.

 

Did this just happen or is it a new install?

Link to comment
Share on other sites

A new install but was ok until i dropped a new template over the top....

 

On your server, not in your shop.

 

There is a register globals fix in the add ons area.

 

Did this just happen or is it a new install?

Link to comment
Share on other sites

A new install but was ok until i dropped a new template over the top....

The template must be an older version of 2.2

Link to comment
Share on other sites

Ok.... please can you be a little more specific... I have loaded my osc site to my domain so I dont host this on my system.

Therefore where, which file should I find php.ini?

 

I've searched for the file but it isn't found!

Link to comment
Share on other sites

If you host in-house -- you can run a search for the file itself and alter it in a text editor.

 

------------------------------------------

 

If you use an off-site host, you need to go into your control panel. (the SITE's control panel, NOT the osc admin panel)

 

Look for an area with a name something like [CGI and Scripted Language Support] ... [Enhanced Script Library] ... that sort of thing. Although several hosts use either vDeck or cPanel -- there are just as many out there that use other control panel applications.

 

Once you find this section, go to the PHP sub-section. Depending on what control panel app your host uses, you either can or can't edit your php.ini from the PHP section. If you don't see that option to edit your php.ini RIGHT THERE, and you can't find any more accurate instructions in the control panel HELP section ... you need to call the tech support line for your host and ask them to edit it for you.

 

-------------------------------------------

 

first thing I would personally do? Check with the template creator to find out if they are working on a 2.2 version of the template! Turning on register_globals shouldn't be done unless you absolutely need it.

Link to comment
Share on other sites

php.ini and php5.ini (if you use PHP 5) is usually located in your /etc/php.d/ folder and/or /var/www/ or /var/www/html/

Or if you don't have access to those folders, try putting it in your root www folder - where your index.html is located.

 

And if you don't see it, just make a text file php.ini and php5.ini with notepad (plain text editor, NOT like MS Word) and upload it using ASCII mode to the above folder(s).

 

-WW

Link to comment
Share on other sites

php.ini and php5.ini (if you use PHP 5) is usually located in your /etc/php.d/ folder and/or /var/www/ or /var/www/html/

Or if you don't have access to those folders, try putting it in your root www folder - where your index.html is located.

 

And if you don't see it, just make a text file php.ini and php5.ini with notepad (plain text editor, NOT like MS Word) and upload it using ASCII mode to the above folder(s).

 

-WW

 

Or even better, just download the first "fix" on this page:

 

http://www.oscommerce.com/community/contributions,5729

 

Which gives you a cut and paste walkthough to fix it. It'll take 15 minutes out of your life... It works, just did it myself and finished literally 2 minutes ago...

 

-WW

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...