Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help! My payment modules don't display during checkout!


Guest

Recommended Posts

Hmmm. My Payment modules have decided to act up. There's always something that bites back in the end right? :)

 

Anyway, I am more or less using the pre-installed modules so I don't understand the problem. I have opted for 4 modules that are well known to me, easy and requires no changes to any files (have had TOO many db problems not to love the basics). The modules are:

 

  • PayPal Website Payments Pro (US) Direct Payments
  • Kreditor (local service), 2 modules
  • [TiM's osC Modules] Version 2007-12-12 :: Posten AB - Postförskott (Inrikes)

 

The odd thing is that it seems that OsC only wants to display one of them at a time. At first it was TiM. And then it changed to PayPal Pro only. I toggled to Paypal Standard and then it showed only that option so... something is being odd here.

 

Could it be PP messing something up? Because I notice that all modules have mysteriously inherited the "Paypal Recommended" order process option.

 

I'm grasping at straws here. It's almost midnight and I've been re-designing for 16h. *phew*

 

XoXo

Jess

Link to comment
Share on other sites

Log in to your osc admin panel and proceed to payment modules.

Try giving different sort order number to any active payment module you are using.

 

Yes. I did that. First thing to check in my book. It did not solve anything. And yes they are all set for the same region as the customers. The modules still show up randomly.

Link to comment
Share on other sites

Hi

 

can you give a url for the site and setup a test account or can I/WE do a test account on your site?

 

 

Thank you for voluntering! I managed to fix the error just 30 min ago. It was caused by, of course, conflicting modules that left ghost code. :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...