Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Fix for Paypal problems passing the total


redmare

Recommended Posts

Following is a very helpful response I got, it is buried in another thread so I thought I should post it again as it is a common problem. it might make a good sticky or should be noted in the documentation. I was setting up a store with a Canadian Paypal account, I thought I had the currency set (deleted all other currencies) but when I tested a transaction the total was not passed to Paypal (it showed a "0"). I had no idea this was related to currency, and spend hours agonzing over this.

 

Member virtue (kristy) posted:

 

Had to 1. Change currency to "AUD" or "GBP" in your case

 

ie

/ if USE_DEFAULT_LANGUAGE_CURRENCY is true, use the following currency, instead of the applications default currency (used when changing language)

define('LANGUAGE_CURRENCY', 'USD');

 

****Change it to AUD or GBP or whatever

 

 

but the crucial step 2. is to

 

Go to Admin panel ---> Go to Configuration ---> Set "Switch to Default Language Currency" to TRUE!!!

 

Hope it helps!

 

I found the script snippet quoted above in the file "languages>english.php" and changed to CAD instead of USD like she said, then changed the control panel setting mentioned above, and the problem was fixed!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...