Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cart does't update after paying with Credit Card


tribalismo

Recommended Posts

Hello all,

 

It is the first time I write in this forum, but I am trying to solve a problem for some days now without luck and after i read all of the posts that could have a solution to my problem I didn't find anything. To my problem now....

 

I have installed oscommerce and for my credit card payments I use DeltaPay. In order to set up DeltaPay to work I used the contribution found here: http://www.oscommerce.com/community/contributions,2674 . After trying to buy something from my store using the credit card, when the customer presses the "confirm order" button, it is redirected to the deltapay secure website to settle out payment and if payment is successful the client is redirected back to my web site's "checkout_success" page. Everything seems to work ok until the point the client is redirected back to the "checkout_success" page when the problem rises.

first problem: The cart even still has the products that the customer has paid for, while it should be empty,

second problem: The customer, even if he paied for the order he can't browse his order at the "account_history" page,

third problem: I can't see the processed orders paied by credit card at the admin control panel, meaning that I really dont know if someone made an order unless I log at the DeltaPay's page and search from there.

By the way, if I use the "cash on delivery" payment method everything works fine.

Thank you in advance for any help.

Link to comment
Share on other sites

Hello, I am having the same problem. The cart does not clear even if a customer is only browsing and adding items to the cart. I can go to the cart and view their activity as if I were another customer. I have noticed that it has their personal information as well. At this point it is unsafe for my customers, anyone who browses the cart can get the personal information for the last person that logged in. I have tried several diff configs and nothing seems to work. Any input will be appreciated, by the way I am using the cart that netfirms offers as a one-click setup. I am not sure which version it is but I am guessing Ver. 1.0, Thanks.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...