Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

contact_us.php


rmsigns

Recommended Posts

i'm having problems receiving my emails from the 'contact us' on my website. i can send myself an email to [email protected] and get it but if someone clicks on the contact us i don't receive it. any suggestions?

here is what my file looks like.

thanks maureen

 

 

 

*/

 

define('HEADING_TITLE', 'Contact Us');

define('NAVBAR_TITLE', 'Contact Us');

define('TEXT_SUCCESS', 'Your enquiry has been successfully sent to the Store Owner.');

define('EMAIL_SUBJECT', 'Enquiry from ' . STORE_NAME);

 

define('ENTRY_NAME', 'Full Name:');

define('ENTRY_EMAIL', 'Email Address:');

define('ENTRY_ENQUIRY', 'Enquiry:');

?>

Link to comment
Share on other sites

It's supposed to go to the STORE_OWNER_EMAIL_ADDRESS as set up in your Admin.

 

You could give this a shot.

 

BACKUP THIS FILE BEFORE MAKING ANY EDITS.

 

At the top of your /catalog/contact_us.php find this line:

 

	  tep_mail(STORE_OWNER, STORE_OWNER_EMAIL_ADDRESS, EMAIL_SUBJECT, $enquiry, $name, $email_address);

Change it to:

 

	  tep_mail('', '[email protected]', EMAIL_SUBJECT, $enquiry, $name, $email_address);

If this doesn't work it must have something to do with your mail setup.

 

I can't help with that.

:blush:

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

yes thanks for the response. i tried adding my name and such but it just brings up a blank page, when i just leave it as is i get the page just not the emails. here is how i have the mail configured. does this seem right?

thanks m

 

 

E-Mail Transport Method smtp

E-Mail Linefeeds CRLF

Use MIME HTML When Sending Emails false

Verify E-Mail Addresses Through DNS false

Send E-Mails true

Link to comment
Share on other sites

Well, there's nothing wrong with the code.

 

I tried the exact code only using my email address and didn't get a blank screen, so I don't know what's going on there.

 

And as I stated before, I won't be any help debugging your mail setup.

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...