Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.


Recommended Posts

I purchased a template for my osCommerce store from Template-Help.com and I uploaded the files as instructed and now I am getting this error message when I try to go into my admin area:


1046 - No database selected


select configuration_key as cfgKey, configuration_value as cfgValue from configuration




Can anyone tell me what is wrong.


Thank you




"Life is short, break the rules, forgive quickly, kiss slowly, love truly, laugh uncontrollably, and never regret anything that made you smile."

Link to comment
Share on other sites

No database selected

you are using wrong/incorrect database


correct the configure.php to the right database name.

Edited by web-project

Please read this line: Do you want to find all the answers to your questions? click here. As for contribution database it's located here!

8 people out of 10 don't bother to read installation manuals. I can recommend: if you can't read the installation manual, don't bother to install any contribution yourself.

Before installing contribution or editing/updating/deleting any files, do the full backup, it will save to you & everyone here on the forum time to fix your issues.

Any issues with oscommerce, I am here to help you.

Link to comment
Share on other sites

I'm hitting the same wall.. have checked & changed names, passwords etc.. in DB_SERVER I've tried both the server IP address and ~~~secureserver.net address. Same result :( The original STORE_SESSIONS was blank, so I tried the 'mysql' option.. nada. I'm assuming this area (below) found at the bottom of the configure.php files is the correct place?? Pls point me in the right direction if not.. (asterisks are all my own work :D )


// define our database connection

define('DB_SERVER', '**.*.***.***');

define('DB_SERVER_USERNAME', '******');

define('DB_SERVER_PASSWORD', '*********');

define('DB_DATABASE', 'osCommerce');

define('USE_PCONNECT', 'false');

define('STORE_SESSIONS', 'mysql');






you are using wrong/incorrect database


correct the configure.php to the right database name.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...