Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Can't switch language


killerwhale65

Recommended Posts

Hi,

 

I can't seem to switch to another language. The first page is OK, but when i click on anything, it goes to default language - again.

 

Strange thing is that this only happens when i have my site on the server. I have the exact same copy running on XAMPP, and there it works fine.

 

Whats wrong?

 

thanks!

Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Link to comment
Share on other sites

in application_top there is $http_get_vars change to $_get for language..

 

Also chek if its working on get what about the session value of currency.

 

In short it might be relatyed to sregister globasl problem.

 

Satish

Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Link to comment
Share on other sites

in application_top there is $http_get_vars change to $_get for language..

 

Also chek if its working on get what about the session value of currency.

 

In short it might be relatyed to sregister globasl problem.

 

Satish

 

hello,

 

i have just noticed that the login session is also not working. I need to login often. But register_globals is set to ON on the server. How can that be?

Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Link to comment
Share on other sites

ok, found the solution.

 

If i use tep_href_link() function everywhere, instead of just entering the link it works. I dont know why this is, cause on my other site i do the same but here it does keep all sessions.

Matthias Thoen

my contribution: Photo Gallery for osCommerce

--check my homepage in my CARD--

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...