Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Only text displayed


Verne

Recommended Posts

Also brand new to osC. Read through the posts but have yet to find a similar case

 

I have installed osC - without any error emssages or other.

 

However when I view my home/base page (opening page). I do not see any graphics. If I use the admin panel and add a pic I can preview and see the image.

Is there perhaps a reason for this.

 

www.africa-web-cams.com/shop

 

Verne

Link to comment
Share on other sites

osC thinks you have SSL installed, and it's on.

 

I can tell from thils line in the HTMl source:

 

<base href="https://africa-web-cams.com/shop/">

Post these lines of code from your /shop/includes/configure.php file:

 

  define('HTTP_SERVER', ''); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', false); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', '');
 define('HTTPS_COOKIE_DOMAIN', '');
 define('HTTP_COOKIE_PATH', '');
 define('HTTPS_COOKIE_PATH', '');

Don't post the entire file.

 

Just what you have for those 7 lines.

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

osC thinks you have SSL installed, and it's on.

 

I can tell from thils line in the HTMl source:

 

<base href="https://africa-web-cams.com/shop/">

Post these lines of code from your /shop/includes/configure.php file:

 

  define('HTTP_SERVER', ''); // eg, http://localhost - should not be empty for productive servers
 define('HTTPS_SERVER', ''); // eg, https://localhost - should not be empty for productive servers
 define('ENABLE_SSL', false); // secure webserver for checkout procedure?
 define('HTTP_COOKIE_DOMAIN', '');
 define('HTTPS_COOKIE_DOMAIN', '');
 define('HTTP_COOKIE_PATH', '');
 define('HTTPS_COOKIE_PATH', '');

Don't post the entire file.

 

Just what you have for those 7 lines.

 

 

 

This is what I have

define('HTTP_SERVER', 'http://africa-web-cams.com');

define('HTTPS_SERVER', 'https://africa-web-cams.com');

define('ENABLE_SSL', false);

define('HTTP_COOKIE_DOMAIN', 'africa-web-cams.com');

define('HTTPS_COOKIE_DOMAIN', 'africa-web-cams.com');

define('HTTP_COOKIE_PATH', '/shop/');

define('HTTPS_COOKIE_PATH', '/shop/');

Link to comment
Share on other sites

This is what I have

define('HTTP_SERVER', 'http://africa-web-cams.com');

define('HTTPS_SERVER', 'https://africa-web-cams.com');

define('ENABLE_SSL', false);

define('HTTP_COOKIE_DOMAIN', 'africa-web-cams.com');

define('HTTPS_COOKIE_DOMAIN', 'africa-web-cams.com');

define('HTTP_COOKIE_PATH', '/shop/');

define('HTTPS_COOKIE_PATH', '/shop/');

Link to comment
Share on other sites

I suggest changing these lines:

 

define('HTTPS_SERVER', 'https://africa-web-cams.com');
define('HTTP_COOKIE_DOMAIN', 'africa-web-cams.com');
define('HTTPS_COOKIE_DOMAIN', 'africa-web-cams.com');
define('HTTP_COOKIE_PATH', '/shop/');
define('HTTPS_COOKIE_PATH', '/shop/');

to

 

define('HTTPS_SERVER', 'http://africa-web-cams.com');
define('HTTP_COOKIE_DOMAIN', '.africa-web-cams.com');
define('HTTPS_COOKIE_DOMAIN', '.africa-web-cams.com');
define('HTTP_COOKIE_PATH', '/');
define('HTTPS_COOKIE_PATH', '/');

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

I suggest changing these lines:

 

define('HTTPS_SERVER', 'https://africa-web-cams.com');
define('HTTP_COOKIE_DOMAIN', 'africa-web-cams.com');
define('HTTPS_COOKIE_DOMAIN', 'africa-web-cams.com');
define('HTTP_COOKIE_PATH', '/shop/');
define('HTTPS_COOKIE_PATH', '/shop/');

to

 

define('HTTPS_SERVER', 'http://africa-web-cams.com');
define('HTTP_COOKIE_DOMAIN', '.africa-web-cams.com');
define('HTTPS_COOKIE_DOMAIN', '.africa-web-cams.com');
define('HTTP_COOKIE_PATH', '/');
define('HTTPS_COOKIE_PATH', '/');

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...