Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

My Account


Guest

Recommended Posts

Hello,

 

When I or a customer presses "My Account" button, this error message appears. Does anyone know how I can fix this?

 

 

 

 

1054 - Unknown column 's.public_flag' in 'where clause'

 

select count(*) as total from orders o, orders_status s where o.customers_id = '5' and o.orders_status = s.orders_status_id and s.language_id = '1' and s.public_flag = '1'

 

[TEP STOP]

Link to comment
Share on other sites

Personally, I'm MYSQL illiterate, but something here might help:

 

Click Me

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Personally, I'm MYSQL illiterate, but something here might help:

 

Click Me

 

 

I tried this but now when I try to checkout, my website goes blank. I don't know how to reverse those two lines that I imported into the database.

Link to comment
Share on other sites

Like I said, I know little about MYSQL.

 

And the error hasn't changed when you click on "My Account"...

:blush:

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Like I said, I know little about MYSQL.

 

And the error hasn't changed when you click on "My Account"...

:blush:

 

 

No problem, it still shows the error but the site shows a button for me to be able to log off and when I press the cart button, I have an item showing that I added. However, when I press "checkout", the website goes blank and I have to refresh.

Link to comment
Share on other sites

:rolleyes: After considerable troubleshooting, my problems ultimately were solved by a shipping.php glitch.

 

Adding this code to phpadmin also was needed.....

 

alter table orders_status add public_flag int DEFAULT '1';

alter table orders_status add downloads_flag int DEFAULT '0';

 

Thanks Jim............

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...