Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

error 1054-Unknown column 'p.products_id' in 'on clause'


Guest

Recommended Posts

Hi,

 

I recently just moved my site to a new hosting co.

The transfer of OScommerce site seems to work fine but I got the following error message during I click on the second to the last "product catagory".

 

go to this link:

http://hypermediaintl.com/catalog/index.ph...54b953e863aa128

 

and click on any product catagory,then this message shows up

 

1054 - Unknown column 'p.products_id' in 'on clause'

 

select count(p.products_id) as total from products_description pd, products p left join manufacturers m on p.manufacturers_id = m.manufacturers_id, products_to_categories p2c left join specials_retail_prices s on p.products_id = s.products_id where p.products_status = '1' and p.products_id = p2c.products_id and pd.products_id = p2c.products_id and pd.language_id = '1' and p2c.categories_id = '270'

 

I can't understand this message. Can you help and point out where might need to be corrected?

 

TIA

 

Spencer

Link to comment
Share on other sites

seems like a database error. I would check your tables in the database to see that they are still intact and named correctly.

A great place for newbies to start

Road Map to oscommerce File Structure

DO NOT PM ME FOR HELP. My time is valuable, unless i ask you to PM me, please dont. You will get better help if you post publicly. I am not as good at this as you think anyways!

 

HOWEVER, you can visit my blog (go to my profile to see it) and post a question there, i will find time to get back and answer you

 

Proud Memeber of the CODE BREAKERS CLUB!!

Link to comment
Share on other sites

seems like a database error. I would check your tables in the database to see that they are still intact and named correctly.

 

 

Thanks for your quick reply.

But when I click on individual product (shows the detail product info page), it works fine(shows no error.)

Or even I click the first couple of catalroies, it works(shows catagory under it).

 

Can you revisit the site and try it?

 

thanks

Link to comment
Share on other sites

Thanks for your quick reply.

But when I click on individual product (shows the detail product info page), it works fine(shows no error.)

Or even I click the first couple of catalroies, it works(shows catagory under it).

 

Can you revisit the site and try it?

 

thanks

http://addons.oscommerce.com/info/4654
Link to comment
Share on other sites

Its database error, You might be using old version of oscommerce which is not supported for MySQL 5.

 

And your hosting company would have MySQL 5.

 

So you need to update couple of pages for Database script which are competible with MySQL 5.

 

HEre is the link for help,

 

http://www.pubwebhost.com/mysql5upgrade.html

 

Let me know if it works for you.

 

Thanks,

Hardik Vyas.

Hardik Vyas

HV InfoTech

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...