Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

need help with index.php


DJYoshaBYD

Recommended Posts

I have the following error on my site

 

Parse error: syntax error, unexpected '.'

 

I was trying to clean up the index.php page so I can write my own stuff in there, and I goofed somewhere.. I just want it blank, so that I can add some text and maybe a pic or 2, but first, I just need it blank.. well, at least the body.. the header, footer, and the menus and whatnot are fine.. I just cant see the page now, and I dont know what I messed up.. here is the output from my index.php file

 

<?php
/*
$Id: index.php,v 1.1 2003/06/11 17:38:00 hpdl Exp $

osCommerce, Open Source E-Commerce Solutions
[url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

Copyright © 2003 osCommerce

Released under the GNU General Public License
*/

define('TEXT_MAIN', 'Welcome to Optical High-Def.<br><br><table border="0" width="100%" cellspacing="5" cellpadding="2"><tr><td class="main" valign="top"></td><td class="main" valign="top"><b></b><br><br><br><br><br><br></td></tr><td class="main" valign="top"></td><td class="main" valign="top"><b></b><br><br><br><br><nobr class="messageStackSuccess">' . $language . '/' . FILENAME_DEFAULT . '</nobr><br><br><nobr class="messageStackSuccess"' . ucfirst($language) . '-></nobr><nobr class="messageStackSuccess"</nobr> <br><br><br><br><nobr><span class="messageStackSuccess"></span></nobr><br><br><br><br><nobr> </nobr><br><br><u></u></a></td></tr><tr><td class="main" valign="top"></td><td class="main" valign="top"><b></td></tr><tr><td class="main" valign="top">' . . '</td><td class="main" valign="top"><b></b><br><br><u></u></a> <br><br><u></u></a> </td></tr></table><br><u></u></a>.<font color="#f0000"><b>' . PROJECT_VERSION . '</b></font>.');
define('TABLE_HEADING_NEW_PRODUCTS', 'New Products For %s');
define('TABLE_HEADING_UPCOMING_PRODUCTS', 'Upcoming Products');
define('TABLE_HEADING_DATE_EXPECTED', 'Date Expected');

if ( ($category_depth == 'products') || (isset($HTTP_GET_VARS['manufacturers_id'])) ) {
define('HEADING_TITLE', 'Let\'s See What We Have Here');
define('TABLE_HEADING_IMAGE', '');
define('TABLE_HEADING_MODEL', 'Model');
define('TABLE_HEADING_PRODUCTS', 'Product Name');
define('TABLE_HEADING_MANUFACTURER', 'Manufacturer');
define('TABLE_HEADING_QUANTITY', 'Quantity');
define('TABLE_HEADING_PRICE', 'Price');
define('TABLE_HEADING_WEIGHT', 'Weight');
define('TABLE_HEADING_BUY_NOW', 'Buy Now');
define('TEXT_NO_PRODUCTS', 'There are no products to list in this category.');
define('TEXT_NO_PRODUCTS2', 'There is no product available from this manufacturer.');
define('TEXT_NUMBER_OF_PRODUCTS', 'Number of Products: ');
define('TEXT_SHOW', '<b>Show:</b>');
define('TEXT_BUY', 'Buy 1 \'');
define('TEXT_NOW', '\' now');
define('TEXT_ALL_CATEGORIES', 'All Categories');
define('TEXT_ALL_MANUFACTURERS', 'All Manufacturers');
} elseif ($category_depth == 'top') {
define('HEADING_TITLE', 'OpticalHD.com');
} elseif ($category_depth == 'nested') {
define('HEADING_TITLE', 'Categories');
}
?>

 

Please help me.. lol

Link to comment
Share on other sites

  • 3 weeks later...

any chance you can help here, too? Just started playing with some of the tips, treading carefully or so I thought. Everything appeared ok until I tried the mydomain/admin/... The homepage loads fine, but this is what I get on the admin link:

 

Parse error: parse error, unexpected ')' in /home/content/...../html/admin/includes/header.php on line 19

 

The only thing I can remember changing is the DYObanner~ gif... tried a few variations to end the line ')' ';' etc, but I'm not familiar with PHP, sorry (nor adding the right box in a thread, erk..)

 

Any help appreciated,

Steve

 

/*
 $Id: header.php 1785 2008-01-10 15:07:07Z hpdl $

 osCommerce, Open Source E-Commerce Solutions
 [url="http://www.oscommerce.com"]http://www.oscommerce.com[/url]

 Copyright © 2008 osCommerce

 Released under the GNU General Public License
*/

 if ($messageStack->size > 0) {
   echo $messageStack->output();
 }
?>

 echo '[url="http://%27%20.%20tep_href_link%28FILENAME_DEFAULT,%20%27%27,%20%27NONSSL%27%29%20.%20%27"]' . tep_image(DIR_WS_IMAGES . 'DYOGbanner4-590.gif');
 [/url]
'; ?>   ' . HEADER_TITLE_ADMINISTRATION . '  |  [url="http://%27%20.%20tep_catalog_href_link%28%29%20.%20%27"]' . HEADER_TITLE_ONLINE_CATALOG . '[/url]  |  [url="http://www.Design-Your-Own-Gifts.com"]' . HEADER_TITLE_SUPPORT_SITE . '[/url]'; ?>Logoff)' : ''); ?>  

Link to comment
Share on other sites

There are a number of mistakes in there and it is not complete code so I suggest reverting to the original and trying again. If it still fails, explain what you are trying to do and post the original and the changed code here (only the relevant parts though).

 

Jack

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

All of My Addons

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...