Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

URL question mark & ampersand replaced by slashes


hp3

Recommended Posts

The problem I'm having is that the question mark & ampersand symbols have been replaced by slashes in the URL. For example:

 

http://www.mysite.com/foo.php?action=send

 

is now

 

http://www.mysite.com/foo.php/action/send

 

Has anyone else experienced this bizarre problem? This happens only with osCommerce pages passing variables to other pages. All other PHP pages not associated with osCommerce on my site have the correct URL format.

Link to comment
Share on other sites

The problem I'm having is that the question mark & ampersand symbols have been replaced by slashes in the URL. For example:

 

http://www.mysite.com/foo.php?action=send

 

is now

 

http://www.mysite.com/foo.php/action/send

 

Has anyone else experienced this bizarre problem? This happens only with osCommerce pages passing variables to other pages. All other PHP pages not associated with osCommerce on my site have the correct URL format.

 

Is it a problem? Whats your issue with it?

 

Its happened as you have set Use Search-Engine Safe URLs (still in development) to true

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Link to comment
Share on other sites

in admin You have set search engine safe url to true.

This code is buggy.

 

So set it to false.

 

if You want seo urls apply seo ultimate by chemo or SEO-g by Enigma.

 

Satish

Ask/Skype for Free osCommerce value addon/SEO suggestion tips for your site.

 

Check My About US For who am I and what My company does.

Link to comment
Share on other sites

Hey Spooks,

 

I am not having any problems, but I am confused because I have another website with Ultimate SEO URLs which does not convert "?" and "&" to "/" It is just annoying having to guess what in the SEF URL is a directory & what is a variable value. At this point I think I'll try to undo the SEF URL modification. Thx.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...