Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Session Configuration settings not being accepted on dedicated linux server


jholdersatx

Recommended Posts

Alright, here's the thing.

 

I've become for the most part fluent with osc milestone 2. My boss has now said that the server's too slow with the mulitple sites we were formerly hosting on a shared host, and we have now moved to a dedicated host. In the transition, I opted to update to RC2.

 

In doing so, I've reinstalled all the old mods that were convenient and helpful.

Problem being now, with the dedicated server, I believe there is some setting I simply cannot figure out to enable file based sessions.

 

It came predefined with "/tmp" as the directory. I check the "/" of the server, sure enough it's there. I chmod it to 777, then chown it to the mysql username, to no avail. I'm still getting the dreaded "cookie_usage" file when adding things to the cart.

So I add a "/tmp" folder to the directory both in catalog, and in the root of the website. Nothing.

 

I've tried every setting, and every combination of a setting I can think of to the point at which now I think there simply must be a server setting that I cannot fathom why it will not work.

 

Does anyone have any insight into a dedicated linux server setting that might need to be modified/enabled/disabled that will allow me to store session files onto it?

I'd appreciate it.

Link to comment
Share on other sites

Did you make changes to both catalog and admin configure.php?

 

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

both configure.php's say the same thing, and they're both empty.

Problem continues.

Link to comment
Share on other sites

Nobody has ANY kind of idea..?

I did everything I could think of in at my disposal, and posting in the forum is my last line of defense before we have to hire a company to fix it.

Link to comment
Share on other sites

Try this one.

 

If you have access to your php.ini file, look for the line containing session.save_path

 

session.save_path = path_to_a valid_directory_for_your_sessions (i.e. /home/pub_html/catalog/sessions/)

Link to comment
Share on other sites

Try this one.

 

If you have access to your php.ini file, look for the line containing session.save_path

 

session.save_path = path_to_a valid_directory_for_your_sessions (i.e. /home/pub_html/catalog/sessions/)

It has been done, I modified it to a folder that I have ownership over, and is chmodded to 777.

Problem continues with the "cookie usage" error response.

Link to comment
Share on other sites

hmm.. small bit of insight though, after browsing the folder, I can tell that the session is active.

So it must be something more complex than just the session's activity, must be some other variable thats prohibiting it from staying active, or some such.

Link to comment
Share on other sites

Regarding "We have detected that your browser does not support cookies"

 

Options:

 

1. You can turn off Force Cookie Use

---OR---

2. If Force Cookie Use is enabled, make these changes to your_store/includes/configure.php

 

In your store/includes/configure.php file

 

define('HTTP_COOKIE_DOMAIN', '.mydomain.com');

define('HTTPS_COOKIE_DOMAIN', '.mydomain.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

Link to comment
Share on other sites

Regarding "We have detected that your browser does not support cookies"

 

Options:

 

1. You can turn off Force Cookie Use

---OR---

2. If Force Cookie Use is enabled, make these changes to your_store/includes/configure.php

 

In your store/includes/configure.php file

 

define('HTTP_COOKIE_DOMAIN', '.mydomain.com');

define('HTTPS_COOKIE_DOMAIN', '.mydomain.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

 

O__O

 

I, I, I, .... wtf?! .__.

That solved it. u_u()

Thank you very much!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...