Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

PHP & MySQL - which versions?


mike_9000

Recommended Posts

I have been asked to set up an e-shop for a friend.

 

The web space provider he is using offers PHP v 5.0 & MySQL v 5.0

 

Can someone please confirm if the latest OSCommerce works with these versions - I read in the specs that it is designed for MySQL v 4.0 & am not sure if this matters or not...

 

Rgds.

Mike

Link to comment
Share on other sites

I suggest you research the differences in SQL 4 and 5 to make sure they will work. My provider upgraded me to PHP 5 without giving me a choice, but I don't seem to be having problems with it. However, a friend of mine who is an SQL programmer told me MySQL 5 upgrade should work fine, so I did it. Now, my shopping cart is down.

 

Good luck with your research.

 

Peace,

David

Link to comment
Share on other sites

It very much depends on which version of osCommerce you are installing:

 

1. osCommerce 2.2 MS2 (060817) should be fine with PHP 5, though some contributions may have some minor problems. Whether it is fully compatible with MySQL 5 is something I doubt. Register Globals needs to be on or you have to apply the Register Global patch files.

 

2. osCommerce RC2 should be compatible with both PHP and MySQL 5, with Register Globals 'off' in php.ini

 

If installing an add-on (Contribution) on an RC2 site then make sure that it says it is compatible with the RC versions of osCommerce. If they have been updated very recently then they should be.

 

Vger

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...