Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

buySAFE


Guest

Recommended Posts

Now when I test my checkout process, get 404 error saying it could not find https://nanaturals.com/oscom/checkout_shipping.php in my directory....but it's there. I assume I'm getting this error because I actived buySAFE then couldn't figure out how to de-activate it, so I very stupidly deleted the directory and now it's searching for a secure document. Is this the reason I'm getting this error? If so, how can I fix this?

 

I'm so sorry, I'm so very new at this...any support is appreciated. Thank you very much! :)

Link to comment
Share on other sites

If you haven't purchased/installed a SSL certificate, you need to start by turning SSL off in your /oscom/includes/configure.php file:

 

  define('ENABLE_SSL', false); // secure webserver for checkout procedure?

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

If you haven't purchased/installed a SSL certificate, you need to start by turning SSL off in your /oscom/includes/configure.php file:

 

  define('ENABLE_SSL', false); // secure webserver for checkout procedure?

 

 

Thanks Germ. :) Makes sense (and I should have followed your signature phrase - what a dummy I am). :) I changed this and attempted to re-upload the configure.php, however, I get the following error "FTP Send File failed: Can't open that file: Permission denied." Do you think this is related to the FTP service, host, or the file itself?

 

I'm so greatful for the replies - I'm so very green with this - your help is SO appreciated. :)

Link to comment
Share on other sites

Sounds like you don't have permissions to overwrite the existing file.

 

You may have to set the file permissions to 666 ( :o bad number!!!) to be able to replace it.

 

Revelation 13:11-18: And I beheld another beast coming up out of the earth; and he had two horns like a lamb, and he spake as a dragon. And he exerciseth all the power of the first beast before him, and causeth the earth and them which dwell therein to worship the first beast, whose deadly wound was healed. And he doeth great wonders, so that he maketh fire come down from heaven on the earth in the sight of men, And deceiveth them that dwell on the earth by the means of those miracles which he had power to do in the sight of the beast; saying to them that dwell on the earth, that they should make an image to the beast, which had the wound by a sword, and did live. And he had power to give life unto the image of the beast, that the image of the beast should both speak, and cause that as many as would not worship the image of the beast should be killed. And he causeth all, both small and great, rich and poor, free and bond, to receive a mark in their right hand, or in their foreheads: And that no man might buy or sell, save he that had the mark, or the name of the beast, or the number of his name. Here is wisdom. Let him that hath understanding count the number of the beast: for it is the number of a man; and his number is six hundred threescore and six." (King James Version)

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Sounds like you don't have permissions to overwrite the existing file.

 

You may have to set the file permissions to 666 ( :o bad number!!!) to be able to replace it.

 

Jim, you're an angel for helping me (no pun intended with the 666 reference)!! But I'm so new to PHP and OSCommerce (and many other things unexplored), would you mind helping me by telling me how I may change the file permissions so I can replace the configure.php file?

 

Thanks again.....and again.....and again..... :)

 

P.S. I'm editing in Dreamweaver - could that be causing a problem?

Link to comment
Share on other sites

You can try to do it with your FTP program, although they are notorious for failing at this task.

 

Most of the time you have to login to the Control Panel provided by your Web Host (NOT OSC!) and do it there.

 

I can't say for sure how because all control panels are not the same.

 

You'll just have to figure that out, or ask your Host.

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Personally, I think it's safer to edit osC files with a pure text editor, like Notepad.

 

I see people pushing an free editor you can download called conText ( I think).

 

I downloaded one called Crimson Editor.

 

Be aware of this:

 

If your server is UNIX (most are) they treat text files differently than your Windows PC does.

 

If you download a file from your server and open it with a text editor and it loses it's formatting (i.e. all the lines "run together") this is what I found works.

 

1. Open a blank text file using Wordpad. Note that Wordpad has 3 options for files, Rich Text, Text, and Unicode Text.Choose TEXT.

 

2. Copy/paste the file from the server into this blank Wordpad doc. It will keep the formatting.

 

3. Then copy/paste it from Wordpad into Notepad (or whatever you use).

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

P.S. I'm editing in Dreamweaver - could that be causing a problem?

 

Hi Renee:

 

I, too, edit in Dreamweaver. All things being equal (but they may not be), you should be able to do as I do and change the permissions through your Dreamweaver screen. Just pull up the directory of remote files, select the desired file, right-click on it, and you'll get a menu that includes the option "Set Permissions..."

 

I think that the worst that can happen is that your new permission settings "don't take" - but it's always worked for me. :rolleyes:

 

Hope all is going well for you,

~Wendy

Link to comment
Share on other sites

Hi Renee:

 

I, too, edit in Dreamweaver. All things being equal (but they may not be), you should be able to do as I do and change the permissions through your Dreamweaver screen. Just pull up the directory of remote files, select the desired file, right-click on it, and you'll get a menu that includes the option "Set Permissions..."

 

I think that the worst that can happen is that your new permission settings "don't take" - but it's always worked for me. :rolleyes:

 

Hope all is going well for you,

~Wendy

 

Worked like a charm! :) Thanks SO much, Wendy! :)

Link to comment
Share on other sites

You can try to do it with your FTP program, although they are notorious for failing at this task.

 

Most of the time you have to login to the Control Panel provided by your Web Host (NOT OSC!) and do it there.

 

I can't say for sure how because all control panels are not the same.

 

You'll just have to figure that out, or ask your Host.

 

 

Thanks again Germ. I tried WoodsWalker suggestion using Dreamweaver to set permission, then I was able to replace the original configure.php file. However, I notice now in testing my catalog, that I have an error message that says:

 

Warning: I am able to write to the configuration file: /home/rmr/public_html/oscom/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

Should I be concerned about this?

 

:) Thank you again! :)

Link to comment
Share on other sites

Personally, I think it's safer to edit osC files with a pure text editor, like Notepad.

 

I see people pushing an free editor you can download called conText ( I think).

 

I downloaded one called Crimson Editor.

 

Be aware of this:

 

If your server is UNIX (most are) they treat text files differently than your Windows PC does.

 

If you download a file from your server and open it with a text editor and it loses it's formatting (i.e. all the lines "run together") this is what I found works.

 

1. Open a blank text file using Wordpad. Note that Wordpad has 3 options for files, Rich Text, Text, and Unicode Text.Choose TEXT.

 

2. Copy/paste the file from the server into this blank Wordpad doc. It will keep the formatting.

 

3. Then copy/paste it from Wordpad into Notepad (or whatever you use).

 

Thanks for the sound advice, Germ. :)

Link to comment
Share on other sites

Thanks again Germ. I tried WoodsWalker suggestion using Dreamweaver to set permission, then I was able to replace the original configure.php file. However, I notice now in testing my catalog, that I have an error message that says:

 

Warning: I am able to write to the configuration file: /home/rmr/public_html/oscom/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

Should I be concerned about this?

 

:) Thank you again! :)

 

Hey Germ! I did my due diligence and searched forums for this error and found another post that had the answer from you! Changed permissions in my cPanel to 400 - no more error! You certainly are a wealth of knowledge! Thanks! :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...