Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

New Site Running Slow


Guest

Recommended Posts

OK, I've re-installed the site 2 times, dropped the old DBs and everything is still running very slow even after I've removed all of the categories and optimized what few images I have up already. Could it be my web host that's causing the problem? It seems to go fast sometimes but then crawls at others, sometimes taking over a minute to display a page, and it's not like the page is coming up and the images are loading slow, the enitre page is blank and then BAM, everything shows up at once. Any ideas or help is truly appreciated.

 

Here's a link to the cart, http://www.creativem2.com/shops/ch/catalog

 

My web host is ipower.com on a shared server.

Link to comment
Share on other sites

I just noticed that its affecting my admin panel as well, everything is slow. I called my webhost and they said since i'm on a shared server that's the reasons it's slow. They tried to sell me an upgrade to a VPS for $50 bucks a month. Has anyone else encoutered issues like this?

Link to comment
Share on other sites

I had a case of marginly slow pages at times, my host agreed it was most likely the server & moved account to faster server for free, had no problems since. Try your pages with another host, there are free ones that would be faster than that.

Sam

 

Remember, What you think I ment may not be what I thought I ment when I said it.

 

Contributions:

 

Auto Backup your Database, Easy way

 

Multi Images with Fancy Pop-ups, Easy way

 

Products in columns with multi buy etc etc

 

Disable any Category or Product, Easy way

 

Secure & Improve your account pages et al.

Link to comment
Share on other sites

No, never heard of that before to my knowledge <_<

I was actually looking at that thread after I had posted this one. I'm just confused on why a fresh clean install would run so slow after running very fast at first.

Link to comment
Share on other sites

I was actually looking at that thread after I had posted this one. I'm just confused on why a fresh clean install would run so slow after running very fast at first.

 

if as you said your ran fast when its first set up but now it suddenly runs very slow and you have not done anything on the site, then chances are your host may just throttle your site - some hosts do not like you 2 use mysql at all whatever they advertise.

 

Ken

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Link to comment
Share on other sites

I'm just confused on why a fresh clean install would run so slow after running very fast at first.

Perhaps you added some specials (in the latest release there is an index on that table for products_id)? Or you added lots of categories (creates at least two queries per category) or a lot of products in the listing (tax rates queries can be a lot of them too).

 

It could also be only one or a few real slow queries. Check that thread to see what contribution to install to investigate that (one from Chemo).

Link to comment
Share on other sites

As you said in our pm your host told you Mysql re-sets itself once it is overloaded - re-set is a diplomatic way of saying 'throttle' - until you meet their greedy demand of $50/m fee. so get a decent host then start following Jan's advice...

 

Ken

commercial support - unProtected channel, not to be confused with the forum with same name - open to everyone who need some professional help: either PM/email me, or go to my website (URL can be found in my profile).

over 20 years of computer programming experience.

Link to comment
Share on other sites

Your problem is ipowerweb your hosting company has 334,000 plus on the same server and they don't think this could be causing issues for you........ I switched from them ages ago. Their database connections are messed up and just in general they do not know how to run a hosting service.

Link to comment
Share on other sites

Your problem is ipowerweb your hosting company has 334,000 plus on the same server and they don't think this could be causing issues for you........ I switched from them ages ago. Their database connections are messed up and just in general they do not know how to run a hosting service.

Lola,

I think you're on the money here. When I woke up this morning the site was running like a dream and I bet by tonight it will be painfully slow again. Does anyone have suggestions on what host to use that are MySQL friendly?

Link to comment
Share on other sites

Lola,

I think you're on the money here. When I woke up this morning the site was running like a dream and I bet by tonight it will be painfully slow again. Does anyone have suggestions on what host to use that are MySQL friendly?

 

I've used a lot of webhosts and I highly recommend Pair.com. Their prices are reasonable, their tech support is FANTASTIC, and their server configurations are great. I'm hosting several MySQL based sites with them, including an OSCommerce site and I couldn't be more pleased.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...