Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

session ids still present HELP!


bennyhill

Recommended Posts

Hi all,

 

I have installed chemos dynamic urls, cdynamic meta tags and i am using this contribution (Spider session remover)

 

i installed these around the end of april, i had one or two older urls show up so i added some 301 rules to redirect these to the new urls in my .htaccess

 

now it seems however that Google in particualr (via google webmaster tools) has gone through my site and has session ids. I have 136 not found errors because of session ids.

 

from may 1st to may 7th Google indexed my site and all the urls have oscisid with them... I need help!!

 

my .htaccess reads

Options +FollowSymLinks
RewriteEngine On 
RewriteBase /


# Skip the next two rewriterules if NOT a spider
RewriteCond %{HTTP_USER_AGENT} !(msnbot|slurp|googlebot) [NC]
RewriteRule .* - [S=2]
#
# case: leading and trailing parameters
RewriteCond %{QUERY_STRING} ^(.+)&osCsid=[0-9a-z]+&(.+)$ [NC]
RewriteRule (.*) $1?%1&%2 [R=301,L]
#
# case: leading-only, trailing-only or no additional parameters
RewriteCond %{QUERY_STRING} ^(.+)&osCsid=[0-9a-z]+$|^osCsid=[0-9a-z]+&?(.*)$ [NC]
RewriteRule (.*) $1?%1 [R=301,L]


RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}
RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}
RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}
RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}


# $Id: .htaccess,v 1.3 2003/06/12 10:53:20 hpdl Exp $
#
# This is used with Apache WebServers
#
# For this to work, you must include the parameter 'Options' to
# the AllowOverride configuration
#
# Example:
#
# <Directory "/usr/local/apache/htdocs">
#   AllowOverride Options
# </Directory>
#
# 'All' with also work. (This configuration is in the
# apache/conf/httpd.conf file)

# The following makes adjustments to the SSL protocol for Internet
# Explorer browsers

<IfModule mod_setenvif.c>
 <IfDefine SSL>
SetEnvIf User-Agent ".*MSIE.*" \
		 nokeepalive ssl-unclean-shutdown \
		 downgrade-1.0 force-response-1.0
 </IfDefine>
</IfModule>

# If Search Engine Friendly URLs do not work, try enabling the
# following Apache configuration parameter
#
# AcceptPathInfo On

# Fix certain PHP values
# (commented out by default to prevent errors occuring on certain
# servers)
#
<IfModule mod_php4.c>
 php_value session.use_trans_sid 0
 php_value register_globals 1
</IfModule>

<IfModule mod_php5.c>
 php_value session.use_trans_sid 0
 php_value register_globals 1
</IfModule>

#i added some 301 from old urls to new
#add 301 rules for existing G cache redirects
Redirect 301 /store http://www.mysite.com


#added 404 rule for redirect
ErrorDocument 404 /error.html

 

In my admin, prevent spider sessions is set to true.

I am not using a robots.txt file.

 

I have changed my user agent in firefox to Googlebot/2.1 (+http://www.googlebot.com/bot.html) and gone through my site, i did not pick up a session id anywhere when going through, i need help!!! how is google getting hold of a session id? it almost appears that the google bot ignored my .htaccess?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...