Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Installation


Recommended Posts

After I uploaded all my files to the hosting server, I have the following error message:

 

FATAL ERROR: register_globals is disabled in php.ini, please enable it!

 

How do I enable register_globals? Is it in configure.php?

 

In /public_html change the code of the file .htaccess to:

 

# -FrontPage-


<Limit GET POST>
order deny,allow
deny from all
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
deny from all
</Limit>
AuthUserFile /home/yourusername/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/yourusername/public_html/_vti_pvt/service.grp
php_flag register_globals On
AuthName yourdomain.com
IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

 

in "yourusername" change to your user name and in yourdomain.com change to your domain.

Link to comment
Share on other sites

It appears your error is referencing the actual file: …/php.ini.

 

Look in your root for this file, open it and there is probably already a statement in there that clearly says to enable or disable globals. In my file for a godaddy hosting account, there are several lines for controling various functionality, the global control looks like this:

 

register_globals=on

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...