Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Strange Shipping Mod issue. Options only show on a refresh.


WS Evolution

Recommended Posts

I am running both Fedex and TNT on a bts based shop. There is a very strange problem where the shipping options from the API systems do not show unless you re-load the page. This only happens the first time you visit the page in any session. I have tried to work out how this has happened and why, but I cant figure it out. Once the page has been refreshed the options show, you can even leave the page and return and it shows first time. I have even logged out and in and it shows first time, but after a certain time if will happen again. I guess when the session time limit runs out. I have tried it with each mod turned off but it still happens the same regardless.

 

Other Points

  • Both mods use the Curl library.
  • The same happens on two servers.

Link to comment
Share on other sites

I am running both Fedex and TNT on a bts based shop. There is a very strange problem where the shipping options from the API systems do not show unless you re-load the page. This only happens the first time you visit the page in any session. I have tried to work out how this has happened and why, but I cant figure it out. Once the page has been refreshed the options show, you can even leave the page and return and it shows first time. I have even logged out and in and it shows first time, but after a certain time if will happen again. I guess when the session time limit runs out. I have tried it with each mod turned off but it still happens the same regardless.

 

Other Points

  • Both mods use the Curl library.
  • The same happens on two servers.

 

 

Maybe this post is best placed in the contribution forums... will try posting it there. Someone please help :'(

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...