Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Altering the security authorities on Dreamweaver


Fsirett

Recommended Posts

I am truly sorry to be such a pain, especially after I have had so much help from you all already.

 

I still have an error message on the "catalog" page, to wit:

 

Warning: I am able to write to the configuration file: /customers/wordofmouthbcn.com/wordofmouthbcn.com/httpd.www/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

I have looked at the system in the admin page and went to the file manager to look at the file.

 

I have located the file and found it would like to open under Dreamweaver. Hence I opened it under their good offices.

 

I found a line saying enable SSL. I assume that I should change this to "true." I await confirmation of this before doing something very stupid.

 

When I close the window has it been changed or do I have to do something more active to ensure the change takes place?

 

I want you all to note I did admit to a lack of ability in the topic description! I said I was an idiot.

 

Frank Sirett

Link to comment
Share on other sites

As an addendum, I went back to the file system and looked at the edit feature.

 

I changed both the 'false' values to 'true' one at a time and together. This does no more to help, than otherwise so I changed them back.

 

What do I change and where is it?

 

Cheers,

 

Frank Sirett

Link to comment
Share on other sites

So far, so good. I have found out that the permissions are changed using a "chmod" command, but I am still at a loss as to where to insert this command. Do I just write it into the file?

 

Sorry, I really am not familiar with this stuff and what I see is slightly confusing. I don't want to make any horrible mistakes

 

Cheers,

 

Frank Sirett

Link to comment
Share on other sites

It is not the contents of the file, it is the file permissions.

 

See here (step 2)

Cheers! I am just about to try that.

 

I just discovered I could change things via the FTP server, quite by accident on another site.

 

I really appreciate your time and trouble.

 

Cheers,

 

Frank Sirett

Link to comment
Share on other sites

Cheers! I am just about to try that.

 

I just discovered I could change things via the FTP server, quite by accident on another site.

 

I really appreciate your time and trouble.

 

Cheers,

 

Frank Sirett

If that does not work, use the web hosts control panel filemanager.

Link to comment
Share on other sites

It worked!

 

I cannot say how much this forum has helped me. I have no end of blindness when I look at masses of solutions to various problems. I must have looked at those files a dozen times and it never registered

 

I also note that the book never mentioned it. Always the way.

 

Thanks all, I do appreciate it

 

Frank Sirett

Link to comment
Share on other sites

If that does not work, use the web hosts control panel filemanager.

 

Sorry, spoke too soon.

 

I used FireFTP to change the settings, but I am not exactly certain that the changes took.

 

The message came back again.

 

I looked at the file manager on my host and that me no option, so I looked at the file manager under the admin section and that did nothing.

 

I reloaded the fileftp files after I changed them on my computer.

 

Do you have anyy other ideas?

 

Cheers,

 

Frank Sirett

Link to comment
Share on other sites

Sorry, spoke too soon.

 

I used FireFTP to change the settings, but I am not exactly certain that the changes took.

 

The message came back again.

 

I looked at the file manager on my host and that me no option, so I looked at the file manager under the admin section and that did nothing.

 

I reloaded the fileftp files after I changed them on my computer.

 

Do you have anyy other ideas?

 

Cheers,

 

Frank Sirett

You need to change the permissions on the web, not on your computer.

 

Do not use the admin filemanager.

 

Did the permissions change? Recheck your webhost filemanager.

Link to comment
Share on other sites

You need to change the permissions on the web, not on your computer.

 

Do not use the admin filemanager.

 

Did the permissions change? Recheck your webhost filemanager.

I have now downloaded SmartFTP and opened my online site using it.

 

I have changed the configure.php to 644 and had it tell me it had changed - no luck.

 

I have changed the configure.php to 444 and had it tell me it had changed - no luck.

 

Do I need to do something else to make this change take hold?

 

Sorry, I am trying everything I can think of and nothing seems to work.

 

Cheers

 

Frank Sirett

Link to comment
Share on other sites

I have now downloaded SmartFTP and opened my online site using it.

 

I have changed the configure.php to 644 and had it tell me it had changed - no luck.

 

I have changed the configure.php to 444 and had it tell me it had changed - no luck.

 

Do I need to do something else to make this change take hold?

 

Sorry, I am trying everything I can think of and nothing seems to work.

 

Cheers

 

Frank Sirett

OK. When this happens, DONT use your FTP program to change it. Your web host server is not allowing the FTP to change it. Go into your control panel given to you by your web host. Then use the file manager/browser in there to change permissions, configure.php should be 444.

If you cant find where to start, show the page to your web host and they should point you in the right place.

Follow the community build:

BS3 to osCommerce Responsive from the Get Go!

Check out the new construction:

Admin Gone to Total BS!

Link to comment
Share on other sites

OK. When this happens, DONT use your FTP program to change it. Your web host server is not allowing the FTP to change it. Go into your control panel given to you by your web host. Then use the file manager/browser in there to change permissions, configure.php should be 444.

If you cant find where to start, show the page to your web host and they should point you in the right place.

Cheers again!

 

I shall go right over and see what happens. I have no idea why this does not work, on another site from the same host I was able to change the permissions (With very careful instructions, I can assure you) but here there is a problem. I shall try it as you read!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...