Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Payment pages now blank!


tonedoggydogg

Recommended Posts

I'm using osCommerce 2.x, SSL is on the domain, and Authorize.Net is the only payment gateway enabled. The modules haven't been touched, and I don't believe I've touched checkout_confirmation.php, checkout_payment.php, or checkout_success.php either.

 

Initially, osCommerce was forwarding to the checkout_success.php page once payment was successful. It would be a nice thank you page, etc.

 

I tinkered with a few settings on Authorize.Net, but changed everything back. I tried to do a test transaction again and now the transaction is successfully processed, but the user is sent to a blank page. The url says authorize.net.../transact.dll but I believe it's actually the checkout_success.php page. Again, the transaction is processed normally and the order is inserted into the database normally.

 

Can anyone please tell me why the page is now coming up blank? Is it because of a switch between SSL and not in the coding? I don't believe I changed any of these files. Please help if you can.

 

Thanks.

Link to comment
Share on other sites

It could be due to a few things. I had similar problems and they were down to a typo in one of the checkout files.

 

Look at your server logs to see if you can get a clue.

 

You could also install another payment method for testing to see if it that works (i.e. if the cash on delivery module works, then it points towards the Authorize.Net files)

Link to comment
Share on other sites

  • 3 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...