Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

checkout_shipping.php not displaying


locaincb

Recommended Posts

I posted this topic under a different forum originally but thought that I might get better results in this forum, sorry if you are viewing this for a second time...

 

This is the first time I have used osCommerce, and I have not had too many troubles configuring and customizing my store but now that I am to the checkout_shipping.php page I get nothing!! From my shopping cart I click on "check out" and I get Internet Explorer cannot display this webpage. I get the same error when I click on the Paypal express check out button??

 

I have done a lot of modifications to the layout and look of the store but have added no contribs and have not messed with any of the functionality. I have no idea where to begin with this issue. This page has never worked for me since I installed the cart so I thought it might start working once I installed & activated my shipping and pay modules but it still does not work. I have enabled table rate shipping, and paypal pro and express. Within my modules menu on my admin page I also have a buySAFE link for the option to enable this buySAFE certificate. I have not enabled this. I have not been able to find anything within the forums or knowledge base on buySAFE so I guess it was included with my hosts installation of osC.

 

If anyone has a clue what I need to do please HELP!

Link to comment
Share on other sites

Look at the URL it's trying to go to when you get the error.

 

If it begins with HTTPS (NOTE THE S!) and you don't have a SSL certificate installed, adjust your configure.php in your catalog to set SSL false.

 

  define('ENABLE_SSL', 'false'); // secure webserver for checkout procedure?

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

I posted this topic under a different forum originally but thought that I might get better results in this forum, sorry if you are viewing this for a second time...

 

This is the first time I have used osCommerce, and I have not had too many troubles configuring and customizing my store but now that I am to the checkout_shipping.php page I get nothing!! From my shopping cart I click on "check out" and I get Internet Explorer cannot display this webpage. I get the same error when I click on the Paypal express check out button??

 

I have done a lot of modifications to the layout and look of the store but have added no contribs and have not messed with any of the functionality. I have no idea where to begin with this issue. This page has never worked for me since I installed the cart so I thought it might start working once I installed & activated my shipping and pay modules but it still does not work. I have enabled table rate shipping, and paypal pro and express. Within my modules menu on my admin page I also have a buySAFE link for the option to enable this buySAFE certificate. I have not enabled this. I have not been able to find anything within the forums or knowledge base on buySAFE so I guess it was included with my hosts installation of osC.

 

If anyone has a clue what I need to do please HELP!

Have you installed any shipping modules in admin? If so, have you given them all different sort orders? Have you set up and used shipping zones?

Link to comment
Share on other sites

Look at the URL it's trying to go to when you get the error.

 

If it begins with HTTPS (NOTE THE S!) and you don't have a SSL certificate installed, adjust your configure.php in your catalog to set SSL false.

 

  define('ENABLE_SSL', 'false'); // secure webserver for checkout procedure?

 

Thanks for the advice that was exactly the issue with moving on from the check out button, now the server moves on to the login.php page.

 

however in resolving this issue I had to reset file permissions for configure.php so that I could write, now I get an error message at the top of my site that says that the file is no longer read only and that is a security risk. I have tried to reset the permission back to read only from Dreamweaver but the change is not happening on the server. Is there a trick to this? Do I need to go into the file manager in admin to take care of this? I could not figure it out either way...

 

Thanks Again!

Link to comment
Share on other sites

The most reliable method is to logon to the control panel provided by your web host (NOT OSC!), and alter permissions there.

;)

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...