Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Header Tags SEO


Jack_mcs
 Share

Recommended Posts

Hey Can anyone help me out, I just installed a fresh version of oscommerce 2.3.1 and ftp'ed the catalog folder, and then ftp'ed the catalog for new shop only folder and when I try to access my admin this is the error I get...

 

Parse error: syntax error, unexpected '.' in /hermes/web08/b2492/moo.oursacredgardencom/oursacredgarden.com/69privates69/includes/functions/general.php on line 846

Link to comment
Share on other sites

Hey Can anyone help me out, I just installed a fresh version of oscommerce 2.3.1 and ftp'ed the catalog folder, and then ftp'ed the catalog for new shop only folder and when I try to access my admin this is the error I get...

 

Parse error: syntax error, unexpected '.' in /hermes/web08/b2492/moo.oursacredgardencom/oursacredgarden.com/69privates69/includes/functions/general.php on line 846

The only change made to that file by Header Tags is a few lines of code. You'll need to look at the line to see what is failing.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

<p>

The only change made to that file by Header Tags is a few lines of code. You&#39;ll need to look at the line to see what is failing.
</p>

 

 

It says these lines code have a syntax error:

 

'open_basedir'../../../admin/includes/functions/ => (int) @ini_get('open_basedir'),

'memory_limit' => @ini_get('memory_limit'),

'error_reporting' => error_reporting(),

'display_errors' => (int)@ini_get('display_errors'),

'allow_url_fopen'../../../admin/includes/functions/ => (int) @ini_get('allow_url_fopen'),

'allow_url_include'../../../admin/includes/functions/ => (int) @ini_get('allow_url_include'),

'file_uploads' => (int) @ini_get('file_uploads'),

'upload_max_filesize' => @ini_get('upload_max_filesize'),

'post_max_size' => @ini_get('post_max_size'),

'disable_functions' => @ini_get('disable_functions'),

'disable_classes' => @ini_get('disable_classes'),

'enable_dl' => (int) @ini_get('enable_dl'),

'magic_quotes_gpc' => (int) @ini_get('magic_quotes_gpc'),

'register_globals' => (int) @ini_get('register_globals'),

'filter.default' => @ini_get('filter.default'),

'zend.ze1_compatibility_mode' => (int) @ini_get('zend.ze1_compatibility_mode'),

'unicode.semantics' => (int) @ini_get('unicode.semantics'),

'zend_thread_safty' => (int) function_exists('zend_thread_id'),

'extensions' => get_loaded_extensions());

Edited by Adamanto75
Link to comment
Share on other sites

Hi Jack

 

Step 6 in the catalog install instructions:

======================================================================================================

6) In includes/database_tables.php, anywhere before the last ?>

 

ADD:

 

/*** Begin Header Tags SEO ***/

define('TABLE_HEADERTAGS', 'headertags');

define('TABLE_HEADERTAGS_CACHE', 'headertags_cache');

define('TABLE_HEADERTAGS_DEFAULT', 'headertags_default');

define('TABLE_HEADERTAGS_SEARCH', 'headertags_search');

define('TABLE_HEADERTAGS_SILO', 'headertags_silo');

 

/*** End Header Tags SEO ***/

 

======================================================================================================

Think it needs added to that:

define('TABLE_HEADERTAGS_KEYWORDS', 'headertags_keywords');

 

At least mine did.

 

Thanks,

Don

Link to comment
Share on other sites

<p></p>

 

 

It says these lines code have a syntax error:

 

'open_basedir'../../../admin/includes/functions/ => (int) @ini_get('open_basedir'),

'memory_limit' => @ini_get('memory_limit'),

'error_reporting' => error_reporting(),

'display_errors' => (int)@ini_get('display_errors'),

'allow_url_fopen'../../../admin/includes/functions/ => (int) @ini_get('allow_url_fopen'),

'allow_url_include'../../../admin/includes/functions/ => (int) @ini_get('allow_url_include'),

'file_uploads' => (int) @ini_get('file_uploads'),

'upload_max_filesize' => @ini_get('upload_max_filesize'),

'post_max_size' => @ini_get('post_max_size'),

'disable_functions' => @ini_get('disable_functions'),

'disable_classes' => @ini_get('disable_classes'),

'enable_dl' => (int) @ini_get('enable_dl'),

'magic_quotes_gpc' => (int) @ini_get('magic_quotes_gpc'),

'register_globals' => (int) @ini_get('register_globals'),

'filter.default' => @ini_get('filter.default'),

'zend.ze1_compatibility_mode' => (int) @ini_get('zend.ze1_compatibility_mode'),

'unicode.semantics' => (int) @ini_get('unicode.semantics'),

'zend_thread_safty' => (int) function_exists('zend_thread_id'),

'extensions' => get_loaded_extensions());

That's not something included with this contribution. It looks more like hacker code. You should post the question in the general forum.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Step 6 in the catalog install instructions:

======================================================================================================

6) In includes/database_tables.php, anywhere before the last ?>

======================================================================================================

Think it needs added to that:

define('TABLE_HEADERTAGS_KEYWORDS', 'headertags_keywords');

 

At least mine did.

Yes, that was missing from the instructions. Thanks for pointing it out.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

That's not something included with this contribution. It looks more like hacker code. You should post the question in the general forum.

 

I think it has something to do with the contribution, I just replaced the general.php file with the one from the original osc2.3.1 and added the lines of code in the admin instructions and my admin let me log in, but everything looked fucked up like the columns were in the middle of the page....

Link to comment
Share on other sites

Hi there, I think i need some help. I may very well be doing something wrong, but idk. When I go to page source, only my index page (which I manually filled in page control) has description/keywords filled..every other page they are blank like so:

<meta name="Description" content="" >
<meta name="Keywords" content="" >

On 'fill tags' page, if I tick "fill all tags' and click update, and then go to an individual product in the admin, the meta tag values (title tag, description tag, keyword tag) all get changed to just the 'product's name'....but still blank in page source. I only have 2 products atm while testing. On one attempt at updating the tags, I noticed 2 pink error messages up top, something along the lines of couldn't find the language page for english (only language I'm using).

 

This entire store is a copy of another store I created where the tags work fine...when I installed it, I added the osc install folder back and used new config files, then after install, updated the db for each individual contributions..don't know if that would help in troubleshooting.

 

OSC 2.3 store, header tags version 3.2.5

 

Any idea of where to look is appreciated. Thanks

Link to comment
Share on other sites

sorry to double post, but the edit time ran out. here are errors, they happen when fill tags with description/keyword override set to 'yes'

Failed to load page from shop: http://www.mysite.com/product_info.php?products_id=30&language=en
Failed to load page from shop: http://www.mysite.com/product_info.php?products_id=29&language=en

Link to comment
Share on other sites

Hi there, I think i need some help. I may very well be doing something wrong, but idk. When I go to page source, only my index page (which I manually filled in page control) has description/keywords filled..every other page they are blank like so:

What does "every other page" mean? Are you saying categories don't have the tags filled in? The products? Have you check the boxes in page control for the categories and products?

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

What does "every other page" mean? Are you saying categories don't have the tags filled in? The products? Have you check the boxes in page control for the categories and products?

 

That might be it. I thought those were only to be used if you were using default descriptions (filling in the lines above those checkboxes).

I can't tell atm because I'm down with a 500 error....didn't think I'd get a response here so quickly, so I went and installed sitemaps seo v1.8...i just noticed that's not compatible with urls 5.0...oops. I'll get back to you on this after I uninstall one of the 2.

Link to comment
Share on other sites

Ok up and running again. But checking the boxes didn't work. On the Page Control, I checked the cats, products, manufacturers under 'defalt tags-english', then hit 'update'..nothing happened.

"Nothing happened?" So the boxes didn't stay checked? Perhaps speaking in so many generalities, if you picked one problem and described it completely and may be able to understand the problem. For example, "web browser title for categories is empty. Categories have titles in admin. Page control shows categories check box enabled." Edited by Jack_mcs

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

First, I want to say thank you to Jack for creating this add on, it works great and the instructions were easy to follow!

 

I installed all the files and got it working, but I seemed to have lost my HTTPS on my website and on the admin section. It was working fine before the Header Tags installations. I checked both of the configure.php files and all the setting are the same as before. Any idea oh how to get the HTTPS to work again? I'm not sure what other information to include, sorry, I'm very new to this.

Thanks,

 

John

Edited by heritageorchards
Link to comment
Share on other sites

Steve and John: Thank you. I appreciate the kind words.

 

John - there isn't anything in the contribution that will cause the loss of https. That's controlled by the configure.php file and that file isn't changed by this contribution. Yo may want to check yours against what is in this thread. Maybe it was changed somehow by mistake?

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Ok, I figured that one out by myself.

 

In the admin section, click on configuration, header tags seo. Then look for the "Display Page Top Title" option and make sure it is set to false.

Link to comment
Share on other sites

Ok, I figured that one out by myself.

 

In the admin section, click on configuration, header tags seo. Then look for the "Display Page Top Title" option and make sure it is set to false.

Only if one doesn't want to use that option. The recommended setting is for it to be enabled.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Just curious, why is it recommended for that feature to be enabled?

The same as with all of the display options - it helps with the SEO of the site.

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...