Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Jack_mcs

Header Tags SEO

Recommended Posts

PHP 7.0

other previous bugs:

cm_pi_description_headertags.php (content product_info) has a problem. When you try to install that module it does not show with a module name and after installed it gets inactive.

 

it did fixed a few and new ones came:

Fatal error: Uncaught Error: Call to undefined method category_tree::getData() in /includes/modules/content/index_nested/cm_in_category_listing_headertags.php:27 Stack trace: #0 /includes/system/versioned/1.0.7.9/osc_template.php(106): cm_in_category_listing_headertags->execute() #1 /templates/default/includes/pages/index.php(23): oscTemplate->getContent('index_nested') #2 /index.php(17): require('/xxx...') #3 {main} thrown in /includes/modules/content/index_nested/cm_in_category_listing_headertags.php on line 27

 

Recreate these steps:

catalog-> Fruit gives the above error

catalog-> Vegetables messes the site structure

 

 

 

Share this post


Link to post
Share on other sites
16 minutes ago, Owl Sauron said:

cm_pi_description_headertags.php (content product_info) has a problem.

Missed that one. Please edit that file and change

const CONFIG_KEY_BASE = 'MODULE_CONTENT_PI_DESCRIPTION_HEADERTAGS';

to

const CONFIG_KEY_BASE = 'MODULE_CONTENT_PI_DESCRIPTION_HEADERTAGS_';

For the second problem, in that file change

      $category_name  = $OSCOM_category->getData($current_category_id, 'name');

to

      $category_name = $GLOBALS['category_tree']->get($GLOBALS['current_category_id'], 'name');

 


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

That last change should be change

      $category_name  = $OSCOM_category->getData($current_category_id, 'name');
      $category_level = $OSCOM_category->setMaximumLevel(1);
      $category_array = $OSCOM_category->buildBranchArray($current_category_id, $category_level);

to

      $category_name = $GLOBALS['category_tree']->get($GLOBALS['current_category_id'], 'name');
      $category_level = $GLOBALS['category_tree']->setMaximumLevel(1);
      $category_array = $GLOBALS['category_tree']->buildBranchArray($current_category_id, $category_level);

 


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites
19 hours ago, Jack_mcs said:

$category_name = $GLOBALS['category_tree']->get($GLOBALS['current_category_id'], 'name'); $category_level = $GLOBALS['category_tree']->setMaximumLevel(1); $category_array = $GLOBALS['category_tree']->buildBranchArray($current_category_id, $category_level);

 

[28-Feb-2021 14:38:38 Europe/Lisbon] PHP Fatal error:  Uncaught Error: Call to undefined method category_tree::setMaximumLevel() in /includes/modules/content/index_nested/cm_in_category_listing_headertags.php:28
Stack trace:
#0 /includes/system/versioned/1.0.7.9/osc_template.php(106): cm_in_category_listing_headertags->execute()
#1 /templates/default/includes/pages/index.php(23): oscTemplate->getContent('index_nested')
#2 /index.php(17): require('/xxx...')
#3 {main}
  thrown in /includes/modules/content/index_nested/cm_in_category_listing_headertags.php on line 28

Share this post


Link to post
Share on other sites
On 2/27/2021 at 6:50 PM, Jack_mcs said:

const CONFIG_KEY_BASE = 'MODULE_CONTENT_PI_DESCRIPTION_HEADERTAGS_';

you forgot that change on the last "include.zip"

 

cm_pi_headertags_seo.php -> language file typo:  Show additional worrds on the product info page.

 

Aside from those, the module seems to work flawlessly

 

 

Share this post


Link to post
Share on other sites
7 hours ago, Owl Sauron said:

you forgot that change on the last "include.zip"

No, the last one only included the fix for the last problem. 

 

7 hours ago, Owl Sauron said:

cm_pi_headertags_seo.php -> language file typo:  Show additional worrds on the product info page.

I don't know what this refers to.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites
8 hours ago, Jack_mcs said:

I don't know what this refers to.

includes/languages/modules/content/product_info/cm_pi_headertags_seo.php

define('MODULE_CONTENT_PRODUCT_INFO_HTS_ADDITIONAL_WORDS_DESCRIPTION', 'Show additional worrds on the product info page.');

you have an "extra" "r".

 

well... theres enough changes/fixes so in my humble opinion a module update would be great since, as it is (at least for me), its now working flawlessly.

 

 

Share this post


Link to post
Share on other sites

Thanks for pointing out the typo. It has been that way from when it was first added but was never noticed.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

Hello Jack,

 

I noticed that after installation of Header Tags SEO every pages shows the ceid p.e.:

www.mysite/index.php?cPath=99&ceid=a9ed5271fea4afeb20f5b3182a7b566c

It has been decades ago that I have seen that?

Share this post


Link to post
Share on other sites
2 hours ago, revamp said:

every pages shows the ceid p.e.:

That's the session ID for Phoenix (maybe Frozen). HTS doesn't have anything to do with the url so that is not caused by the addon. It might be that you are using the wrong set of files for the update. Please sure the ones you use match your oscommerce version.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

In 1.0.7.15 file /admin/header_tags_seo.php

line 979

<script src="//ajax.googleapis.com/ajax/libs/jqueryui/1.12.1/jquery-ui.min.js"></script>
});

is the }); needed.

 

Share this post


Link to post
Share on other sites
8 hours ago, MyBookShop said:

is the }); needed.

No, it isn't. You can probably delete the line above it too. I have tested it but I don't think it is needed in Phoenix.

Thank you for posting the mistake. Please let me know of any others you may find.

Edited by Jack_mcs

Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

Hi Jack,

Today I noticed that from admin page control, I had entered the keywords assigned to the "product_info.php" pages but these do not appear when I edit the products web page (same issue for the title and description too).

On the other hand, no problem for other generic pages of type "index.php", "shipping.php", etc.

Do you know where the problem is coming from?
Could this be because I am using rewritable URLs?

And if so, how to get around this problem?

Cordially.

admin_page_control.jpg

xml_product_page_render.jpg

Edited by milerwan

Osc v2.3.4 BS "custom"
PHP 7.3 compatible (710 modified files => o_O')

Share this post


Link to post
Share on other sites

@milerwanI tested it, in Phoenix, and it works as expected. It could have to do with the cache of the url rewriter so you may want to try clearing that. If that's not it, please let me know what version of oscommerce you are using so I can test in that version.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

I have clearing cache of URL rewriting but nothing changes.
Version of oscommerce is 2.3.4BS and I'm using Ultimate SEO V 2.2d.

My base version is 3.3.4 and I have changed files to update to 3.3.5.
Maybe I have forgotten to changes some files during the process ?


Osc v2.3.4 BS "custom"
PHP 7.3 compatible (710 modified files => o_O')

Share this post


Link to post
Share on other sites

I tested that setup and it worked correctly so it seems to be something on your end. You could try running the reset cache option in Ultimate SEO and then disable it. Reload the page on the shop side to make sure the rewriter is turned off and see if that helps. You may need to clear your browsers cache.

Version 3.3.4 is quite old. The current one is 3.3.13. It's possible one of the updates would fix the problem though I don't recall that problem ever being mentioned. Also, while you say your version is 3.3.4, your image shows version 3.3.6. So it might be that you have files from each that is causing the problem.

Also, unrelated to this, I meant to mention your keywords. You have to be careful when using too many keywords. While google doesn't use them, they do check them. If they find too many entries in that tag that are not mentioned on the page, they may consider it to be "keyword stuffing" and that can cause the page's ranking to suffer. There's no limit on the number of keywords you can have but they need to be mentioned on the page for best results.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

OK I understood my concern...
Need to check the "Root" radio button and put number to add "page_description" and/or "page_keywords" (or "page_title").

Finally it works well. Sorry for the inconvenience.

NB: In includes/functions/header_tags, into the "function tep_header_tag_page($file)", I have quoted this script below because, when no "page_description" or no "page_keywords" registered, the page displays the "pathinfo($_SERVER['SCRIPT_FILENAME'])" with default keywords even if the "default_keywords" radio button is not checked.
But maybe it is the purpose of this script... ^^
 

  //if nothing else is set, force the page name and default settings, if present   
  $path_parts = pathinfo($_SERVER['SCRIPT_FILENAME']);
  $pageName = substr($path_parts['basename'], 0, strpos($path_parts['basename'], '.')) . ' ';
  $pageName = ucwords(preg_replace("/[^A-Za-z0-9]/", " ", $pageName));

  if (! tep_not_null($header_tags_array['title'])) $header_tags_array['title'] = $pageName . (tep_not_null($tmpTags['def_title']) ? HEADER_TAGS_SEPARATOR_DESCRIPTION . ' ' . $tmpTags['def_title'] : '');
  //if (! tep_not_null($header_tags_array['title_alt'])) $header_tags_array['title_alt'] = (tep_not_null($tmpTags['prod_title_alt']) ? HEADER_TAGS_SEPARATOR_DESCRIPTION . ' ' . $tmpTags['def_title'] : '');
  if (! tep_not_null($header_tags_array['description'])) $header_tags_array['description'] = $pageName . (tep_not_null($tmpTags['def_desc']) ? HEADER_TAGS_SEPARATOR_DESCRIPTION . ' ' . $tmpTags['def_desc'] : '');
  if (! tep_not_null($header_tags_array['keywords'])) $header_tags_array['keywords'] = $pageName . (tep_not_null($tmpTags['def_keywords']) ? HEADER_TAGS_SEPARATOR_KEYWORD . ' ' . $tmpTags['def_keywords'] : '');
  if (! tep_not_null($header_tags_array['logo']))  $header_tags_array['logo'] = $pageName . (tep_not_null($tmpTags['def_logo_text']) ? HEADER_TAGS_SEPARATOR_DESCRIPTION . ' ' . $tmpTags['def_logo_text'] : '');

 


Osc v2.3.4 BS "custom"
PHP 7.3 compatible (710 modified files => o_O')

Share this post


Link to post
Share on other sites

The default items are used when the page isn't set up with its own tags. Checking the use default checkboxes is not needed in those cases. For pages like are set to use tags from the items, like categories and products, you need to be sure to run fill tags so that there are not any empty items. I've seen the failure in the case of the latter where there were missing entries. I didn't think it was worth adding code to check since not having filled in items defeats the purpose of the addon.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

Hello Jack,

 

I have 3 languages in my shop, when I want to change a category I see in every field the 3 languages except with Alternate Title Text, Alternate URL Text and Alternate Breadcrumb Text, in these 3 I see only 1 language ?

 

Share this post


Link to post
Share on other sites

I didn't have that version in a shop with multiple languages but I just tried a quick add to an existing shop and you are correct. To allow it to work until a proper fix is made, you can made these changes (untested). In categories.php find

      </div>
      <div class="tab-pane fade" id="section_images_content" role="tabpanel">

and change it to

    <?php
    require_once('includes/functions/header_tags_general.php');
    include_once('includes/header_tags_seo/htc_products_display.php');
    ?>
      </div>
      <div class="tab-pane fade" id="section_images_content" role="tabpanel">

In includes/hooks/admin/categories/headertags_seo_display.php change injectLanguageForm to injectLanguageFormXX


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

PHP 7.1 and up
Phoenix 1.0.8.0

When you go to manufacturers

Notice: Undefined index: title in /includes/header_tags.php on line 221

Notice: Undefined index: title in /includes/header_tags.php on line 222

Notice: Undefined index: keywords in /includes/header_tags.php on line 225

Notice: Undefined index: title in /includes/modules/header_tags_seo/header_tags_opengraph.php on line 31

Notice: Undefined index: desc in /includes/modules/header_tags_seo/header_tags_opengraph.php on line 32

 

Description - Header Tags module installs but does not get active for some reason

 

If you use the Breadcrumb

Notice: Constant BOX_HEADING_HEADERTAGS_TAGCLOUD already defined in /includes/languages/english/header_tags_seo.php on line 3

Notice: Constant TEXT_SEE_MORE already defined in /includes/languages/english/header_tags_seo.php on line 4

Notice: Constant TEXT_SEE_MORE_FULL already defined in /includes/languages/english/header_tags_seo.php on line 5

Notice: Constant HTS_OG_AVAILABLE_STOCK already defined in /includes/languages/english/header_tags_seo.php on line 6

Notice: Constant HTS_OG_PRICE already defined in /includes/languages/english/header_tags_seo.php on line 7

Notice: Constant HTS_TEXT_VIEWING already defined in /includes/languages/english/header_tags_seo.php on line 9

Fatal error: Uncaught Error: Call to undefined method category_tree::getData() in /includes/modules/content/header/cm_header_breadcrumb_headertags.php:52 Stack trace: #0 /includes/system/versioned/1.0.7.9/osc_template.php(106): cm_header_breadcrumb_headertags->execute() #1 /templates/default/includes/components/header.php(15): oscTemplate->getContent('header') #2 /templates/override/includes/components/template_top.php(61): require('...') #3 /templates/default/includes/pages/product_info.php(13): require('/...') #4 /product_info.php(25): require('/...') #5 {main} thrown in /includes/modules/content/header/cm_header_breadcrumb_headertags.php on line 52

Share this post


Link to post
Share on other sites

This addon hasn't been coded to work with your version. The last (fatal error) is due to the class usage being changed so the command in the code will no longer work. There are too many changes to fix that to post here so you will have to wait for the next version if you want to use this addon.


Support Links:

For Hire: Contact me for anything you need help with for your shop: upgrading, hosting, repairs, code written, etc.

Get the latest versions of my addons

Recommended SEO Addons

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×