Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

Authorize.net Cannot Connect to server, check cURL and server settings


Recommended Posts

I have been at this for 2 days now. I have been consulting with CRE support since I am running the Pro version of their software. Basically, the supplied Auth.net module is not working for me. Originally I thought it could be the curl directory. I tried every possible combination and turns out I had it on there right the first time. After some more messing around and a day later with CRE support they tell me the reason it wont work is because I did not have OpenSSL compiled. So, I recompile with that option, change nothing else and then my secure.domain.com stops working entirely. I reinstall the SSL cert and this solves that problem, again though, same error "The server cannot connect to Authorize.net. Please check your cURL and server settings."


I am wondering if there is anything else I might need for this to work? I have config settings listed here hyperformanceparts.com/phpinfo.php


OpenSSL seems to be working, along with an up to date verion of curl. Is there anything else it could be?


Maybe iptables firewall is blocking connection?

Link to comment
Share on other sites

I have now added curlSSL and nothing helps. Also I have turned off iptables firewall and tried again with no luck. Anyone have any ideas?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...