Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Questions about SEO URLs


Guest

Recommended Posts

Dear Friends...

 

I see some contributions with name SEO URLs...

 

My question is, what is the advantage or disadvantages in use this SEO URLs??? I read some thinks but still don't understand for what is used for...

I see some sites using this but i still dont understand perfectly witch advantages can give us ...

 

 

I see also on the contributions pages allot of SEO URLs contributions, witch one works perfectly in osCommerce RC2a???

 

 

Sorry my english....

 

 

Any help would be appretiated...

 

Best Regards

KarTunes

João Carrolo

Link to comment
Share on other sites

Dear Friends...

 

I see some contributions with name SEO URLs...

 

My question is, what is the advantage or disadvantages in use this SEO URLs??? I read some thinks but still don't understand for what is used for...

I see some sites using this but i still dont understand perfectly witch advantages can give us ...

I see also on the contributions pages allot of SEO URLs contributions, witch one works perfectly in osCommerce RC2a???

Sorry my english....

Any help would be appretiated...

 

Best Regards

KarTunes

João Carrolo

 

There are proven SEO benefits to having keywords in the url. ULTIMATE SEO URLs by Chemo imo is the best coded and easy to install. version 2.1d

Link to comment
Share on other sites

Today i try to implement on of this contributions, ans when i click in one product, the IE give me an error page where tell me the product page don't exist....

 

Now i will try again with the latest release to see what happens...

 

 

Best Regards

João Carrolo

KarTunes

Link to comment
Share on other sites

Agree with Jack. Chemo's contribution is very robust, it is almost always user error with installation.

 

double check your .htaccess.

 

Rob

Rob Bell - Inspired Graphix

Customising osCommerce in Australia, and the world!

View my profile for web and email links.

 

I'm sorry, but i cannot offer Free support via PM etc, and osCommerce forums prohibit me from putting any reference to paid support in my signauture.

However viewing my profile may provide links to my website or something like that which you may find useful.

Link to comment
Share on other sites

My store is inside a directory with the name /pt-kartunes/ so my .htaccess it's described below

 

 

And i still having the same error...

 

# $Id: .htaccess 1739 2007-12-20 00:52:16Z hpdl $

#

# This is used with Apache WebServers

#

# For this to work, you must include the parameter 'Options' to

# the AllowOverride configuration

#

# Example:

#

# <Directory "/usr/local/apache/htdocs">

# AllowOverride Options

# </Directory>

#

# 'All' with also work. (This configuration is in the

# apache/conf/httpd.conf file)

 

# The following makes adjustments to the SSL protocol for Internet

# Explorer browsers

 

#<IfModule mod_setenvif.c>

# <IfDefine SSL>

# SetEnvIf User-Agent ".*MSIE.*" \

# nokeepalive ssl-unclean-shutdown \

# downgrade-1.0 force-response-1.0

# </IfDefine>

#</IfModule>

 

# If Search Engine Friendly URLs do not work, try enabling the

# following Apache configuration parameter

 

# AcceptPathInfo On

 

# Fix certain PHP values

# (commented out by default to prevent errors occuring on certain

# servers)

 

# php_value session.use_trans_sid 0

# php_value register_globals 1

 

Options +FollowSymLinks

RewriteEngine On

RewriteBase /pt-kartunes/

 

RewriteRule ^(.*)-p-(.*).html$ product_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-c-(.*).html$ index.php?cPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-m-([0-9]+).html$ index.php?manufacturers_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pi-([0-9]+).html$ popup_image.php?pID=$2&%{QUERY_STRING}

RewriteRule ^(.*)-t-([0-9]+).html$ articles.php?tPath=$2&%{QUERY_STRING}

RewriteRule ^(.*)-a-([0-9]+).html$ article_info.php?articles_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pr-([0-9]+).html$ product_reviews.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-pri-([0-9]+).html$ product_reviews_info.php?products_id=$2&%{QUERY_STRING}

RewriteRule ^(.*)-i-([0-9]+).html$ information.php?info_id=$2&%{QUERY_STRING}

 

 

Any help will be appretiated...

 

Best Regards

João Carrolo

KarTunes

Link to comment
Share on other sites

SEO-G is the best along with Header Tags controller.

 

Use that and do some manual rewriting of your URLS in a .htaccess or apache config file and you'll get nice URLs like I have done here for my site:

 

http://www.assaultshirts.com/mens_t_shirts

Assault

If you want to find it you'll have to google "Assault T-Shirts" because posting my damn url in my signature is against the forum rules.

T-Shirts with an edge

Powered by OSCommerce + about 20 different custom addons and some Wordpress

Link to comment
Share on other sites

I'm still struggling with this. I have my store in the root, was moved from /catalog/store to root. I changed the rewrite in .htaccess file from /catalog/store/ to just /. My links with SEO turned on were not working for my categories before. All others were fine. Now, when I turn on the SEO and click on a category, it just sits there and acts like it is opening it, but never does anything. I can go to the other links and they are fine.

 

Any ideas on what is going wrong for me?

Link to comment
Share on other sites

I'm still struggling with this. I have my store in the root, was moved from /catalog/store to root. I changed the rewrite in .htaccess file from /catalog/store/ to just /. My links with SEO turned on were not working for my categories before. All others were fine. Now, when I turn on the SEO and click on a category, it just sits there and acts like it is opening it, but never does anything. I can go to the other links and they are fine.

 

Any ideas on what is going wrong for me?

 

I'd need a site link please.

Link to comment
Share on other sites

Thanks Robert for Looking at this. I have turned back on the SEO. The information links work. It is the links to the categories that just seem to wait forever.

 

www.deliverycards.com

 

Pretty much as I thought, SEO URLs is functioning perfectly and generating the correct urls. BUT your server is not responding to the redirects in .htaccess.

 

Usual culprits server side are ..

 

1) WinDoze server

2) mod_rewrite not enabled on the server

3) AllowOveride is not given sufficient permission and therefore .htaccess cannot work

Link to comment
Share on other sites

Thanks for checking that out. I can't find a httpd.conf file or http.conf file to try to switch the allowoveride. So, does this mean I am screwed?

 

Does anyone know if I'll have the same problem with the SEO-G contribution? Just thought I'd ask before I tried it out. I'm on a netfirms server.

Link to comment
Share on other sites

Thanks for checking that out. I can't find a httpd.conf file or http.conf file to try to switch the allowoveride. So, does this mean I am screwed?

 

Does anyone know if I'll have the same problem with the SEO-G contribution? Just thought I'd ask before I tried it out. I'm on a netfirms server.

 

Here's a link I did a quick google ..

 

http://www.epinions.com/content_273049554564

 

Search the review for . .

 

Netfirms does not provide AllowOverride for .htaccess

Link to comment
Share on other sites

I don't published my web with this contribution, i', runing on my computer the complete address is http://127.0.0.1/pt-kartunes/

 

I have a version runing on the web in http://www.kartunes.online.pt/pt-kartunes/ but i don't have SEO URLs contributions installed, i prefer to blow the local website and not the live site... Because that, first i try on my computer and only after that i publish the changes.....

Link to comment
Share on other sites

I'm still struggling with this. I have my store in the root, was moved from /catalog/store to root. I changed the rewrite in .htaccess file from /catalog/store/ to just /. My links with SEO turned on were not working for my categories before. All others were fine. Now, when I turn on the SEO and click on a category, it just sits there and acts like it is opening it, but never does anything. I can go to the other links and they are fine.

 

Any ideas on what is going wrong for me?

 

If you move your site directory you will have to clear the cache via the seo url's section of your admin.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...