Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Security Risk in configure.php


rajan

Recommended Posts

When I open our webshop www.humaniversityshop.nl I get the following error:

 

Warning: I am able to write to the configuration file: /home/tanju.nl/public_html/shop/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

I have not done any changes lately so I have no idea why this error occurs or what to do with it.

 

Does anyone know what this is and what I can do about it?

 

Thanks for help!

Link to comment
Share on other sites

Its a problem with the file permissions, not the contents.

 

From the knowledge base:

 

Reset the permissions on catalog/includes/configure.php to 644 (if you are still getting the warning message at the top of the page after setting this configure.php files to 644 then set the catalog/includes/configure.php file to 444 which is read only - this happens on some servers that have been updated for security reasons).

Link to comment
Share on other sites

Its a problem with the file permissions, not the contents.

 

From the knowledge base:

 

Reset the permissions on catalog/includes/configure.php to 644 (if you are still getting the warning message at the top of the page after setting this configure.php files to 644 then set the catalog/includes/configure.php file to 444 which is read only - this happens on some servers that have been updated for security reasons).

 

 

What's the meaning 644 or 444? where i can made it???sorry i am newbie...:D

Link to comment
Share on other sites

i was knew what the solve of problem....may be u need going to cpanel and find the file public_html >find your store folder installation your site>includes>checklist configure.php and klik change permisson and then you made it to 444 (uncheck write)

may be can help u,,,

:D

Link to comment
Share on other sites

i was knew what the solve of problem....may be u need going to cpanel and find the file public_html >find your store folder installation your site>includes>checklist configure.php and klik change permisson and then you made it to 444 (uncheck write)

may be can help u,,,

:D

 

Thanks for this juskesemek, worked for me! After a full week of trying all sorts of cures.

It was the only way I could get it to work was by going to CPanel as you said and changing it from there.

 

Many, Many thanks for the advice my friend!

 

:D

Link to comment
Share on other sites

it wont let me change the permissions!? I have tried via ftp and threw control panel but i change it, click ok. then i go back and it is back to what it was!?

Link to comment
Share on other sites

it wont let me change the permissions!? I have tried via ftp and threw control panel but i change it, click ok. then i go back and it is back to what it was!?

 

I found the only way to change it was to go to CPanel, drill down through the files until I got to the catalog/includes/configure.php file.

Right clicked it, then 'changed permissions' to 444 then it was OK.

 

Left the other configure file at catalog/admin/includes/configure file at 644 permissions.

Hope this helps.

Link to comment
Share on other sites

well it wont let me change it lol i change it and then check and its back to how it was before. either way the pink has gone at the top of the page lol duno...just duno...

Link to comment
Share on other sites

Sadly to say, I pulled out a few hairs over that same error. With my CPanel, I had to sign out then log back on for it to reflect the change to me. You will probably see the change next time you sign on to your control panel.

 

Michelle

Link to comment
Share on other sites

Yes if you are running on a server using cPanel, then cPanel is often the only method for updating file permissions.

 

As Michelle has said, occasionally you will need to log out then back in for things to work. Just one of those things :D

 

Rob

Rob Bell - Inspired Graphix

Customising osCommerce in Australia, and the world!

View my profile for web and email links.

 

I'm sorry, but i cannot offer Free support via PM etc, and osCommerce forums prohibit me from putting any reference to paid support in my signauture.

However viewing my profile may provide links to my website or something like that which you may find useful.

Link to comment
Share on other sites

I Love Firefox :rolleyes:

 

Our server doesn't have cPanel, and I couldn't find how to change properties in Dreamweaver. But then I checked out the FireFTP Extension in Firefox, and with a simple right-click -> properties I could change the permissions for configure.php. Easy...

 

Thanks for help!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...