Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Help: Order Confirmation Error When Completed


jwalker

Recommended Posts

Hello

 

When Placing an order on our site everything goes fine. You put in your addess and credit card info and when you hit confirm order, instead of taking you back to the home page as you are suppossed to, it takes you to an error page, you do not receive a confirmation email, but the order goes through. The Error Page States:

 

"Warning: mail(): Failed to connect to mailserver at "mail.reachone.com" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\OLYNET\GINELECTRONICS.COM\store\includes\classes\email.php on line 520

 

Warning: mail(): Failed to connect to mailserver at "mail.reachone.com" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\OLYNET\GINELECTRONICS.COM\store\includes\classes\email.php on line 520

 

Warning: Cannot modify header information - headers already sent by (output started at D:\OLYNET\GINELECTRONICS.COM\store\includes\classes\email.php:520) in D:\OLYNET\GINELECTRONICS.COM\store\includes\functions\general.php on line 33"

Link to comment
Share on other sites

Hello

 

When Placing an order on our site everything goes fine. You put in your addess and credit card info and when you hit confirm order, instead of taking you back to the home page as you are suppossed to, it takes you to an error page, you do not receive a confirmation email, but the order goes through. The Error Page States:

 

"Warning: mail(): Failed to connect to mailserver at "mail.reachone.com" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\OLYNET\GINELECTRONICS.COM\store\includes\classes\email.php on line 520

 

Warning: mail(): Failed to connect to mailserver at "mail.reachone.com" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\OLYNET\GINELECTRONICS.COM\store\includes\classes\email.php on line 520

 

Warning: Cannot modify header information - headers already sent by (output started at D:\OLYNET\GINELECTRONICS.COM\store\includes\classes\email.php:520) in D:\OLYNET\GINELECTRONICS.COM\store\includes\functions\general.php on line 33"

Your email setting are wrong. The email daemon is not listening on port 25 of the mail.reachone.com server. Check with your hosting company for the correct port number and host name of the email server. Hosting company frequently use a different port number to cut down on DOS attacks.

 

Ben

Link to comment
Share on other sites

This just started happening- it has been fine for a year. I contacted my ISP and they stated:

 

"We haven't made any recent changes to our mail servers. Are you getting this error consistently or has it only cropped up this one time? Have you made sure that your SMTP port is set to 25 and that your SMTP server name is "mail.reachone.com"? Also make sure that your e-mail client is configured to log in to the SMTP(outgoing) server with the same credentials as the POP3(incoming) server."

 

So it looks like we are set up right. Correct?

Link to comment
Share on other sites

This just started happening- it has been fine for a year. I contacted my ISP and they stated:

 

"We haven't made any recent changes to our mail servers. Are you getting this error consistently or has it only cropped up this one time? Have you made sure that your SMTP port is set to 25 and that your SMTP server name is "mail.reachone.com"? Also make sure that your e-mail client is configured to log in to the SMTP(outgoing) server with the same credentials as the POP3(incoming) server."

 

So it looks like we are set up right. Correct?

OK, it sounds like your port number / server name are correct; however, something has changed.

 

Are you using the standard osCommerce email capability or have you added one of the email contributions like phpmail or SMTP Authentication? If you have been using the standard email capability up to this point, it does not support SMTP authentication. Your hosting company may be telling you they now require SMTP authentication to connect to the server.

 

Looking at the reachone.com website, they require SMTP Authentication. If you don't have one of the email contribution loaded that support authentication, you will need to load one. I suggest this one.

 

It wouldn't be the first time a hosting company claims nothing has changed when something has.

 

Ben

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...