Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Configure.php file permission error


ScrapbookSupplies

Recommended Posts

Does anyone happen to know what permissions can be used to secure the configure.php file and rid the index of this error message (pasted below), if 644, 444 and 400 all fail? My webhost keeps defaulting to 600, which is Owner read, write.

 

 

Warning: I am able to write to the configuration file: /home/scrapcha/public_html/scrapbooksuppliesdirect/shop/catalog/includes/configure.php

 

Thanks for the help,

Jeanne

Link to comment
Share on other sites

Hi Jeanne, I have just solved this problem. I went to the control panel of my domain name, found something within the control panel called the 'File Manager' found the correct file - catalog/includes/configure.php and was given an option to change the permissions of the file - I changed it from 644 to 444 (or read only) - this corresponded on my control panel to user, group and world all being ticked for 'read' - my error message then disappeared - make sure you actually get to the fiie itself and not just the folder it resides in

 

Hope this helps.

 

WDBMagic

 

Does anyone happen to know what permissions can be used to secure the configure.php file and rid the index of this error message (pasted below), if 644, 444 and 400 all fail? My webhost keeps defaulting to 600, which is Owner read, write.

 

 

Warning: I am able to write to the configuration file: /home/scrapcha/public_html/scrapbooksuppliesdirect/shop/catalog/includes/configure.php

 

Thanks for the help,

Jeanne

Link to comment
Share on other sites

Hi Jeanne, I have just solved this problem. I went to the control panel of my domain name, found something within the control panel called the 'File Manager' found the correct file - catalog/includes/configure.php and was given an option to change the permissions of the file - I changed it from 644 to 444 (or read only) - this corresponded on my control panel to user, group and world all being ticked for 'read' - my error message then disappeared - make sure you actually get to the fiie itself and not just the folder it resides in

 

Hope this helps.

 

WDBMagic

 

Hi, I too keep getting this error, I have changed my permissions to 644 and 444 and neither works unfortunately, has anyone any idea waht else could be wrong?

 

Thanks

 

Pete

 

Actually, just found out, when I change it to 444 it automatically switches back to 644...

Link to comment
Share on other sites

I have the same problem - maybe its my host, hostmonster.com. I will check their tech. support.

 

..err never mind. Well, I guess there might be somethign to learn - I couldnt' do it via an FTP client, via the host's cPanel "Unlimited FTP" applet, but I was able to change the permissions via the cPanel "File Manager."

 

I hope you find an easy way on your host too.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...