Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

please suggest . should i install new osc rc2 or upgrade my ms2 site


sinryder

Recommended Posts

hey guys i have recently switch host and they are running php5 and mysql 5 . my site was build on osc 2.2-MS2 n running fine on php 4.4 . but after the upgrade i have had so many problems.. fixed few but still everyday i find something new is wrong.... i have installed more then 20 contributions to this site but my main mistake was i never applied any of the updates to it.

2 main problems im facing right now is

1) my paypal ipn payment method is screwd

2) most of my images are broken on my site ..... even the small corner's on the left / right boxes..

 

ok the question i have is.. should i install a fresh version of oscommerce-2.2rc2a and then reinstall all the contributions and just transfer the products and customers database to it.. ??

or should i follow the steps and start doing all the updates 1st) ms2 update-20060817.txt) 2nd) osc v2.2 RC1 Upgrade and then 3) osc v2.2 RC2 ...

 

which will be a better / solid option for me to do???

 

your help is very much apprecaited

Link to comment
Share on other sites

Since we are on the subject.

Before changing host I am trying to copy my site on my pc using xamp. My site was build on osc 2.2-MS2 and is running fine on php 4.3.9 but xamp is using php 5.2.5. I am facing more problem than sinryder. I had to change many "<?=" (are they called operators?) to <?php echo but still I am missing something. Do you think it is worth the trouble trying to copy my site (to xamp and later to a new host)?

 

The only thing is that i am using a template but if i am about to spend a month trying to copy the thing which may have problems i might just as well redesign the whole thing!!

 

What is your opinion???

 

Ps images for some reason are not working under catalog/images but if i move them in the same level with catalog they are working

 

ex if catalog is under localhost/catalog images are not working under localhost/catalog/images but under localhost/images

Link to comment
Share on other sites

My site was build on osc 2.2-MS2 and is running fine on php 4.3.9 but xamp is using php 5.2.5.

There is a previous version of xxamp that allows you to switch from php 5 to php 4. I use it on my 2.2-MS2 test site. I'm not sure which release version it is (it's NOT the latest) but google the forums as it was discussed here a few months back.

"Outside of a dog, a book is man's best friend.

Inside of a dog, it's too dark to read."

 

GROUCHO (1895-1977)

Link to comment
Share on other sites

hey guys i have recently switch host and they are running php5 and mysql 5 . my site was build on osc 2.2-MS2 n running fine on php 4.4 . but after the upgrade i have had so many problems.. fixed few but still everyday i find something new is wrong.... i have installed more then 20 contributions to this site but my main mistake was i never applied any of the updates to it.

2 main problems im facing right now is

1) my paypal ipn payment method is screwd

2) most of my images are broken on my site ..... even the small corner's on the left / right boxes..

 

ok the question i have is.. should i install a fresh version of oscommerce-2.2rc2a and then reinstall all the contributions and just transfer the products and customers database to it.. ??

or should i follow the steps and start doing all the updates 1st) ms2 update-20060817.txt) 2nd) osc v2.2 RC1 Upgrade and then 3) osc v2.2 RC2 ...

 

which will be a better / solid option for me to do???

 

your help is very much apprecaited

 

I don't think it's safe to import ms2 database to RC2 installation store.

It depends what contributions are installed? Some contribution will not work on RC2 or php 5.x.

I suggest you manual update from ms2 -> RC1 -> RC2 on test/demo site before going to live site. This is how I moved my site with 40+ contributions (can't even remember what has installed) and modified layout store.

 

Old share hosting (php 4.4.2/Apache 1.3.x/mysql 4.1) to new VPS (php 5.2.5/Apache2handle/mysql 5)

Link to comment
Share on other sites

There is a previous version of xxamp that allows you to switch from php 5 to php 4. I use it on my 2.2-MS2 test site. I'm not sure which release version it is (it's NOT the latest) but google the forums as it was discussed here a few months back.

 

Thank you but after understanding that I nnede an earlrier version of Php and Apache I sa that xamp by default haw the latest versions but has also a "get more" option from where you can download and use earlier versions of apache and php!!!

 

 

As for that

"I don't think it's safe to import ms2 database to RC2 installation store"

 

i didnt get it but I will ty something similar on atest site!!!

 

BTW where are the updates??? i ont see them on the download section are they contributions???

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...