Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Clicking MyAccount & Checkout goes: 404 Not found!


Guest

Recommended Posts

I take this, for me awkward, occasion to salute you my new community.

And introduce my self in this forum.

 

Since yesterday I have become a osCommerce user, and withit an activist in this forum.

 

I would rather like to write this first time about how great it was hat everything went smoothly and nice, but being it not the case, I thank you to be here for Help.

 

My V2.2 RC2 online merchant version, was pre installed on my server and with the help of "Fantastico De Luxe" only a few clicks away of being online and working.

 

Everything worked well, until i clicked my self into my account, or tried to make a new one.

 

Then showed me browser this very known warning:

 

Not Found

 

The requested URL /account.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

 

The same result as when i tried to clicked on the check out.

The Cart works well though!

 

I went to my File manager on the admin panel, and looked for the account.php file.

It IS there! at the same level as all the other files like the .htaccess and the checkout_*.php files too.

 

What should I do, it´s there something I´ve missed on the installation, do I need any extra module?

 

I thank any help in forward.

 

Gustavo Vilera.

Link to comment
Share on other sites

The most common reason for this is if you said "Yes" to SSL at installation, but you have no SSL certificate installed.

 

Look closley at the URL it's trying to go to.

 

Does it begin with HTTPS (NOTE THE S!!)?

 

If it does, and you haven't installed an SSL certificate - That's the problem.

 

To turn SSL "off", edit your configure.php files.

 

Change this:

 

  define('ENABLE_SSL', 'true'); // secure webserver for checkout procedure?

to

 

  define('ENABLE_SSL', 'false'); // secure webserver for checkout procedure?

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Thank you for the fast answer!

 

And YES that was the deal!!!!!!

The browser tried to go in a HTTPS and I remember to have accepted this Certificate option, thinking I allready had one.

 

I changed the code as told! and everything functions just as it should!

 

Thank you a lot GERM!!!!!!

 

G.V.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...