Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Guest

[Contribution] STS v4

Recommended Posts

Sorry, but what is PWA? If I was troubleshooting this, I would start with the header.php file from both contributions to see what is conflicting. If I did not find anything there, I would compare both contributions entirely.

 

 

K first of all, PWA is Purchase Without Account contrib.

second, STS replaces the header.php, but PWA does not

third, i have checked perty much all of my installed modules and only two modify header.php and they are not conflicting (its the paypal one..)

fourth- i am finally at my own computer and here is the code that is coming under conflict:

 

// START STS 4.1
$sts->restart_capture ('applicationtop2header');
// END STS 4.1

 

if that code is disabled, the site runs fine (no STS it seems like)

 

 

needless to say...im stumped

 

help! :D (please :P)


STUFF TO DO:

-change boxes on left side to desired style

-remove default mini pictures (cartoon ones)

-modify some of the text colors

-change text headings ("Whats new here" etc.)

-add shipping modules

-add credit card module that allows to stay on my site

-remove all or all but 3 of the "new products" at bottom of main screen

-change button styles

-add SSL

-add the products from TIGI

Share this post


Link to post
Share on other sites
K first of all, PWA is Purchase Without Account contrib.

second, STS replaces the header.php, but PWA does not

third, i have checked perty much all of my installed modules and only two modify header.php and they are not conflicting (its the paypal one..)

fourth- i am finally at my own computer and here is the code that is coming under conflict:

 

// START STS 4.1
$sts->restart_capture ('applicationtop2header');
// END STS 4.1

 

if that code is disabled, the site runs fine (no STS it seems like)

 

 

needless to say...im stumped

 

help! :D (please :P )

Check your application_top.php file. You should have the following code at the end of the file:

 

 

// PWA BOF
 if (tep_session_is_registered('customer_id') && $customer_id == 0 && substr(basename($PHP_SELF),0,7)=='account') tep_redirect(tep_href_link(FILENAME_SHOPPING_CART));
// PWA EOF
 // START STS 4.1
 require (DIR_WS_CLASSES.'sts.php');
 $sts= new sts();
 $sts->start_capture();
 // END STS 4.1
?>

 

Also, check your column_right.php file. It should have the following code at the beginning of your file:

 

 

// START STS 4.1
if ($sts->display_template_output) {
 $sts->restart_capture ('content');
} else {
//END STS 4.1
 require(DIR_WS_BOXES . 'shopping_cart.php');

 if (isset($HTTP_GET_VARS['products_id'])) include(DIR_WS_BOXES . 'manufacturer_info.php');

// PWA EOF
 if (tep_session_is_registered('customer_id') && $customer_id > 0 ) include(DIR_WS_BOXES . 'order_history.php');
// PWA BOF

 

And at the end of this same file you should have this code:

 

 // START STS 4.1
}
// END STS 4.1
?>

 

STS and PWA make modifications to the above same files so you needed to merge the differences to make them work. :thumbsup:


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Hey all,

 

I've got the latest STS v4.2 up and running, and have a question about adding new, custom infobox contributions. I want to add one of the Login Box contributions to my current store (ie, http://www.oscommerce.com/community/contri...arch,login+box). However (and pardon my ignorance here), I can't figure out if there is a way to incorporate a contribution like this into the STS. Is it possible to make a $newcustominfobox variable and then call that like everything else is called in the STS setup? Or, maybe I am missing something really basic?

 

Anyhow, any help would be much appreciated. The STS is really remarkable and has saved me and my colleagues SO much time -- so, many thanks, to everyone working on it. All the best, cheers,

 

brian

Share this post


Link to post
Share on other sites
Hey all,

 

I've got the latest STS v4.2 up and running, and have a question about adding new, custom infobox contributions. I want to add one of the Login Box contributions to my current store (ie, http://www.oscommerce.com/community/contri...arch,login+box). However (and pardon my ignorance here), I can't figure out if there is a way to incorporate a contribution like this into the STS. Is it possible to make a $newcustominfobox variable and then call that like everything else is called in the STS setup? Or, maybe I am missing something really basic?

 

Anyhow, any help would be much appreciated. The STS is really remarkable and has saved me and my colleagues SO much time -- so, many thanks, to everyone working on it. All the best, cheers,

 

brian

in catalog/includes/modules/sts_inc/sts_column_left.php (sts_column_right.php)

require(DIR_WS_BOXES . 'newlogin.....php'); in sts_col - whatever is file name

$sts->restart_capture ('your_variable, 'box'); // Get your new box

and put $yourvariable then ...

Share this post


Link to post
Share on other sites

is it bug ?

when you using specific content tempalte for product and product is out of stock STS doesn't show default message "Product is not found" but the template (without pictures descriptions etc), but botton add to cart is there and when clicked redirects to cart

 

this product_info template drives me crazy

Share this post


Link to post
Share on other sites
in catalog/includes/modules/sts_inc/sts_column_left.php (sts_column_right.php)

require(DIR_WS_BOXES . 'newlogin.....php'); in sts_col - whatever is file name

$sts->restart_capture ('your_variable, 'box'); // Get your new box

and put $yourvariable then ...

 

Check the manual in Section 3 - Bill has listed instructions ;) I use the sts_column_left or sts_column_right pages, depending on where on my page I want the new box to show up (rather than the sts_user_code file mentioned in the instructions).

 

Tracy


~Tracy
 

Share this post


Link to post
Share on other sites
Hey all,

 

I've got the latest STS v4.2 up and running, and have a question about adding new, custom infobox contributions. I want to add one of the Login Box contributions to my current store (ie, http://www.oscommerce.com/community/contri...arch,login+box). However (and pardon my ignorance here), I can't figure out if there is a way to incorporate a contribution like this into the STS. Is it possible to make a $newcustominfobox variable and then call that like everything else is called in the STS setup? Or, maybe I am missing something really basic?

 

Anyhow, any help would be much appreciated. The STS is really remarkable and has saved me and my colleagues SO much time -- so, many thanks, to everyone working on it. All the best, cheers,

 

brian

How to add a new infobox variable(tag) to STS:

Add this code to sts_user_code.php

$sts->start_capture();

require(DIR_WS_BOXES . 'infobox_name.php');

$sts->stop_capture('infobox_name', 'box');

 

The above would create a STS user tag called $infobox_name


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

Good afternoon folks,

 

I have the same problem as many others on this thread, namely turning gzip compression to 'true' only generates an empty site. I've searched the forum and tried to implement all the tips i found, but still without any progress. This is what i've done:

 

Tried adding the lines:

 

php_flag zlib.output_compression On

php_value zlib.output_compression_level 5

 

to the top of my catalog/.htaccess file. This generated a "500 internal server error". In the belief that i had done something wrong i searched the apache documentation and instead i added the code they wrote about:

 

<Location />

 

# Insert filter

SetOutputFilter DEFLATE

 

# Netscape 4.x has some problems...

BrowserMatch ^Mozilla/4 gzip-only-text/html

 

# Netscape 4.06-4.08 have some more problems

BrowserMatch ^Mozilla/4\.0[678] no-gzip

 

# MSIE masquerades as Netscape, but it is fine

# BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

 

# NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48

# the above regex won't work. You can use the following

# workaround to get the desired effect:

BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html

 

# Don't compress images

SetEnvIfNoCase Request_URI \

 

\.(?:gif|jpe?g|png)$ no-gzip dont-vary

 

 

# Make sure proxies don't deliver the wrong content

Header append Vary User-Agent env=!dont-vary

 

</Location>

This also gave an "500 internal server error". Could it be that my webhosting has turned off the posibility of changing the php-settings in .htaccess? After this i had a look at my server configuration admin/server_info.php and it seems like gzip is already enabled

_SERVER["HTTP_ACCEPT_ENCODING"] gzip, deflate

 

If I turn gzip compression off in the admin it works fine, but if i turn it on and use only level "0" i get the problem with the empty body tag.

 

The STS contribs i am using are the following:

STSv42HTS259

STSv4_2_Infobox_Templates

 

While searching the forum i fond someone (Think it wass bill kellum) refering to a one-line fix for the problem that he could post if needed, does anyone know if this is the abovementioned .htaccess line, or is it something else?

 

Any other ideas as to what might be wrong?

Cheers,

anders

Share this post


Link to post
Share on other sites
Good afternoon folks,

 

I have the same problem as many others on this thread, namely turning gzip compression to 'true' only generates an empty site. I've searched the forum and tried to implement all the tips i found, but still without any progress. This is what i've done:

 

Tried adding the lines:

 

php_flag zlib.output_compression On

php_value zlib.output_compression_level 5

 

to the top of my catalog/.htaccess file. This generated a "500 internal server error". In the belief that i had done something wrong i searched the apache documentation and instead i added the code they wrote about:

 

 

This also gave an "500 internal server error". Could it be that my webhosting has turned off the posibility of changing the php-settings in .htaccess? After this i had a look at my server configuration admin/server_info.php and it seems like gzip is already enabled

 

 

If I turn gzip compression off in the admin it works fine, but if i turn it on and use only level "0" i get the problem with the empty body tag.

 

The STS contribs i am using are the following:

STSv42HTS259

STSv4_2_Infobox_Templates

 

While searching the forum i fond someone (Think it wass bill kellum) refering to a one-line fix for the problem that he could post if needed, does anyone know if this is the abovementioned .htaccess line, or is it something else?

 

Any other ideas as to what might be wrong?

Cheers,

anders

Try by setting zlib.output_compression On in your php.ini file if you have access to it.

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I think this is what you want:

 

 

 

To remove the header for the info boxes:

Open ./includes/classes/boxes.php

 

Inside the code, you will find this class definition:

 

class infoBoxHeading extends tableBox {

 

Go at the end of the class definition and edit this line:

 

$this->tableBox($info_box_contents, true);

 

Replace it with:

 

$this->tableBox($info_box_contents, false);

Hope it helps,

 

Bill Kellum

 

Thanks Bill that fixed it!

Share this post


Link to post
Share on other sites

Hi everyone

 

Now I'm having trouble modifying the $content I'm sure it's just me being incredibly stupid but I cannot find how to do this.

 

For example on my frontpage I have managed to delete the original text which is installed with osCommerce but how can I modify the part which shows up the 'New Products for'

 

Is there a way to put for example a "best sellers" box (showing multiple products), "new products" box (showing multiple products) and some text?

 

Also the $languagebox centers itself automatically is there a way to change this so that I can align it to the right, etc...?

 

And finally I am using CSS to sort out the fonts and everything but I don't seem to be able to change the font for the infoboxs..??

 

Sorry for all the questions I hope someone can help me out. lol

 

Thanks in advance for any help

Share this post


Link to post
Share on other sites
Hi everyone

 

Now I'm having trouble modifying the $content I'm sure it's just me being incredibly stupid but I cannot find how to do this.

 

For example on my frontpage I have managed to delete the original text which is installed with osCommerce but how can I modify the part which shows up the 'New Products for'

 

Is there a way to put for example a "best sellers" box (showing multiple products), "new products" box (showing multiple products) and some text?

 

Also the $languagebox centers itself automatically is there a way to change this so that I can align it to the right, etc...?

 

And finally I am using CSS to sort out the fonts and everything but I don't seem to be able to change the font for the infoboxs..??

 

Sorry for all the questions I hope someone can help me out. lol

 

Thanks in advance for any help

Create page index.php_0.html and put what you want there

I'm afraid you cannot put boxes in front page

There are contribution for scrolling best sellers, new products etc, but in column lef/right

About CSS - install infoboxes addon for STS, its works quite well with CSS, but keep mind that the changes will affect olso on advance search and also purchesed modules

if you want to have default content in your front box

just put $content, or $content$, depends of STS configuration

Share this post


Link to post
Share on other sites

if you want to have default content in your front box

just put $content, or $content$, depends of STS configuration

Sorry mistake

if you want to have default content on front page put $contetn

Share this post


Link to post
Share on other sites
Try by setting zlib.output_compression On in your php.ini file if you have access to it.

 

Im believe i do not have acess to the php.ini file since i only have an account on a webhotel, and not my own server. I asked the support at the webhotel and they said they compress all html by default, but when i test it with some tool on the internet it tells me it not compressed, and only when i turn gzip compression on in the osc admin it tells me it's compressed. But then it doesnt work, as described above.

 

Any more clues?

Share this post


Link to post
Share on other sites

Just a quick note on my install of STSv42HTS259

 

I have STS-2_01 & HeaderTags_V_2.5.9 working flawlessly on both a live shop, and local development server.

 

I tryed to install STSv42HTS259 but with a few problems.

 

1. Bestseller_scroll shows the best sellers but will not scroll.

 

2. Headertags show only when you are clicked on the product itself. No catagorie tags show.

 

3. Using all products "allprod.php" when require(DIR_WS_FUNCTIONS . 'clean_html_comments.php'); exists in includes/ header_tags I get.

 

Fatal error: Cannot redeclare clean_html_comments() (previously declared in d:\web_sites\dvbhardware\dvbhardware\includes\functions\clean_html_comments.php:13) in d:\web_sites\dvbhardware\dvbhardware\includes\functions\clean_html_comments.php on line 13

 

I do not have require(DIR_WS_FUNCTIONS . 'clean_html_comments.php'); in my HTCv2.5.9 in the header_tags.php and if I remove it in the STS version 42HTS259 I cannot display the product, shows error that the clean_xxx is missing. But the allprods.php displays as it should.

 

Jimmy


I'm not a coder just a splicer.

Share this post


Link to post
Share on other sites
Guest

a quick little customization for STS... I added the cart contents (item count and $ value) into my header (based on the cart in header contrib)

 

Took about 30 seconds :)

 

add to /includes/modules/sts_inc/sts_user_code.php

$sts->template['cartinfo'] = '<a href=' . tep_href_link(FILENAME_SHOPPING_CART, '') . ' class="headerNavigation"> basket: ' . $cart->count_contents() .'  / ' . $currencies->format($cart->show_total()) . '</a>'

then add the $cartinfo variable to your header -- voila!

Share this post


Link to post
Share on other sites

Just a quick note on my install of STSv42HTS259

 

I have STS-2_01 & HeaderTags_V_2.5.9 working flawlessly on both a live shop, and local development server.

 

I tryed to install STSv42HTS259 but with a few problems.

 

1. Bestseller_scroll shows the best sellers but will not scroll.

 

I don't know wich best sellers scroll I'm using, but the file in include/boxes is bestseller2.php

so when I upgrade I change definition in catalog/includes/modules/sts_inc/column_left from bestseller.php to bestseller2.php and its workin perfectly now.

Hope this info is usefull for you

Any one have sucess to implament Advanced Shopping Cart with STS4 and Infobox, or AJAX search, or Ultra PICS ?

Share this post


Link to post
Share on other sites
a quick little customization for STS... I added the cart contents (item count and $ value) into my header (based on the cart in header contrib)

 

Took about 30 seconds :)

 

add to /includes/modules/sts_inc/sts_user_code.php

$sts->template['cartinfo'] = '<a href=' . tep_href_link(FILENAME_SHOPPING_CART, '') . ' class="headerNavigation"> basket: ' . $cart->count_contents() .'  / ' . $currencies->format($cart->show_total()) . '</a>'

then add the $cartinfo variable to your header -- voila!

I love it when STS users make their custom STS tags available for everyone else to enjoy. It makes STS all the more user friendly. :thumbsup:

 

I've been thinking about where would be the best place to "post" these that would inspire other users to contribute their custom STS tags.

 

I would like to hear from everybody on this. Do you think it would be best to start a new contribution site on osCommerce.com called "STS addons"? I don't like posting them on this forum because they just get lost among all of the pleas for help. What do you guys think?

 

Chris has already started a contribution site called "STS Power Pack". Do you think this would be a could place to upload various STS addons? I don't like posting the addons onto the main STS contribution page because new users get confused on which download is the latest "full package" if you know what I mean.

 

I would really like to know what everyone else thinks would be the best place just for custom STS user tags such as the one above.

 

Thanks,

 

Bill Kellum

Edited by bkellum

Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites
I love it when STS users make their custom STS tags available for everyone else to enjoy. It makes STS all the more user friendly. :thumbsup:

 

I've been thinking about where would be the best place to "post" these that would inspire other users to contribute their custom STS tags.

 

I would like to hear from everybody on this. Do you think it would be best to start a new contribution site on osCommerce.com called "STS addons"? I don't like posting them on this forum because they just get lost among all of the pleas for help. What do you guys think?

 

Chris has already started a contribution site called "STS Power Pack". Do you think this would be a could place to upload various STS addons? I don't like posting the addons onto the main STS contribution page because new users get confused on which download is the latest "full package" if you know what I mean.

 

I would really like to know what everyone else thinks would be the best place just for custom STS user tags such as the one above.

 

Thanks,

 

Bill Kellum

 

Perfect

non-programers like me will have more choise, I mean when you install STS4 you have a lot of difficulties with other contributions, if we share such an information will be very usefull for everyone

Share this post


Link to post
Share on other sites
Guest

STS Power Pack contribution has been created for STS add-ons, so feel free to place your custom code there.

 

If you have STS code related to a contribution, please also put the link to this contribution, not only its name.

Share this post


Link to post
Share on other sites

Hi,

 

Im obviously doing something stupid here...

 

I installed sts on a new installlation, copied files, changed header_tags to 777, ran database setup.php... I am now trying to do the configuration... bI want to set use STS to true, but it wont change from false...

 

simple permissions problem? but where... :|

Share this post


Link to post
Share on other sites
STS Power Pack contribution has been created for STS add-ons, so feel free to place your custom code there.

 

If you have STS code related to a contribution, please also put the link to this contribution, not only its name.

I agree that this is the best place to post custom code (including custom STS tags) for STS VERSION 4 AND ABOVE.

 

 

 

So...hopefully all of you STS gurus out there will make your nice "hacks" :rolleyes: available to everyone else. I will start posting there as well.

 

 

 

Looking forward to all of your contributions.


Bill Kellum

 

Sounds Good Productions

STS Tutorials & more: STSv4.6, STS Add-ons (STS Power Pack), STS V4 Forum STS Forum FREE TEMPLATE

Share this post


Link to post
Share on other sites

any ideas how to create layer when when add to card is clicked

I would like to show message to custumer "You have added 1 item your basket", or something like this

Today i read bkellum posts about java scripte, but still cannot figure the advanced shopping cart to work with STS. When I turn off STS js script work well, but it don't when I eneable it. Any help (advice) is welcome

Share this post


Link to post
Share on other sites

Hello,

 

Just a simple question with using STS and Header Tags Controller together. In my admin section in header tags controller in text control all in the list are still red...do I need to add the header code to all in the files in the catelog folder with these 2 contribution working together??

 

Thanks,

 

Mike. :rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×