Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

noob need help


slimjim70

Recommended Posts

Hi,

I need help,

its the dreaded register globals problem.

before anyone gets funny and starts saying 'read the stickys'

or 'do a search you numpty' , let me explain.

I have,

i have read as much as my brain will take.

 

I have installed osc on bluehost.

i have edited the .htaccess and php.ini files so they say register_globals = on

i even tried the patch supplied somewhere by Vger.

 

nothing works.......

i get the same error....

 

this is my last hope obi wan.....

or else i will have to get another cart.

 

thanks

 

Slim

Link to comment
Share on other sites

Which osC version? The latest one you can download (RC2a) should not have a problem with a register_globals = on setting.

 

Hi,

 

thanks for answering so quickly (and not taking the piss)

I originally installed via fantasico on Bluehost (dont know what ver)

the did a 'manual' which i got from the oscommerce site.

which is 2.2rca2 i believe.

 

thanks

Link to comment
Share on other sites

the did a 'manual' which i got from the oscommerce site.

which is 2.2rca2 i believe.

Yes, but did you change all the files too? The message Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory. is found in catalog/includes/application_top.php in the older versions, but will only be shown in RC2a when your version of PHP is less than 4.2 (then you still need register_globals is on, but there are at least two contributions that patch that, the newest is the shortest and easiest IMO).

Link to comment
Share on other sites

Hi,

 

I changed all the .htaccess files inc the one in the catalog folder.

and when i tried the patch i used the one vger said to use .

ie: not the ones that he said were 'spam' ?

 

I'm really stuck.

 

I guess i should try a fresh install? again.

 

thanks

 

Slim

Link to comment
Share on other sites

I guess i should try a fresh install? again.

That's the fastest way I guess. Just changing .htaccess files doesn't bring you to RC2a (the webserver might be configured to ignore .htacess files...)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...