Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Configuring Login, Shopping Cart, Checkout, etc pages


hanbar

Recommended Posts

Does anyone know how to fix this?

 

I want to remove the header and replace the footer on all the pages of my store. I have been successfull on all the front pages (the ones showing the merchandise, and the index page), but I cannot do it on the login, shopping cart and checkout pages. I have tried commenting them out, and deleting them entirely, but they always come up with the oscommerce logos and clip art on them. I have replaced the oscommerce logos in the oscommerce.gif file and the file that contains the footer pictures with my own graphics, but the oscommerce logos keep coming up. I have also repalced the clipart, but the changes are not appearing on these pages.

 

Also, for these same pages, the left and right columns do not contain the edits that I made to the column_left and column_right files. While they work as I want them on the front pages of the store, they revert back to their original form on the back pages.

 

Does anyone know why, or how to fix them? If you want to see the problem, go on www.anbeadsjewelry.com, and click Shop Now.

 

Thanks so much,

Hannah

Link to comment
Share on other sites

Does anyone know how to fix this?

 

I want to remove the header and replace the footer on all the pages of my store. I have been successfull on all the front pages (the ones showing the merchandise, and the index page), but I cannot do it on the login, shopping cart and checkout pages. I have tried commenting them out, and deleting them entirely, but they always come up with the oscommerce logos and clip art on them. I have replaced the oscommerce logos in the oscommerce.gif file and the file that contains the footer pictures with my own graphics, but the oscommerce logos keep coming up. I have also repalced the clipart, but the changes are not appearing on these pages.

 

Also, for these same pages, the left and right columns do not contain the edits that I made to the column_left and column_right files. While they work as I want them on the front pages of the store, they revert back to their original form on the back pages.

 

Does anyone know why, or how to fix them? If you want to see the problem, go on www.anbeadsjewelry.com, and click Shop Now.

 

Thanks so much,

Hannah

 

Hiya,

Possibly something to do with the frames, of more likely your configure.php files are pointing to another installation of OSC?

Sometimes you're the dog and sometimes the lamp post

[/url]

My Contributions

Link to comment
Share on other sites

Hiya,

Possibly something to do with the frames, of more likely your configure.php files are pointing to another installation of OSC?

 

But do you know how to fix it? Assuming that I can make my config.php file writable, what am I looking for? And what am I changing it to?

Link to comment
Share on other sites

Post them here or PM me, please remove any sensitive Data like passwords data base name etc

Here you go (do you know what I have to change the permissions to, to make the file "writable?":

 

 

<?php

/*

$Id: configure.php,v 1.14 2003/07/09 01:15:48 hpdl Exp $

 

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.anbeadsjewelry.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://fisher.globat.com/~anbeadsjewelry.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'anbeadsjewelry.com');

define('HTTPS_COOKIE_DOMAIN', 'fisher.globat.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/shop/');

define('DIR_WS_HTTPS_CATALOG', '/shop/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/usr/local/psa/home/vhosts/anbeadsjewelry.com/httpdocs/shop/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'xxxxxxx');

define('DB_SERVER_PASSWORD', 'xxxxxx');

define('DB_DATABASE', 'xxxxxxxxg');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

Link to comment
Share on other sites

Try this one, worth pointing out that your SSL was set incorrectly + when i went to your SSL site the images were there.

Have they cached your site on the server or you uploaded it to there?

Back up first please!

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.anbeadsjewelry.com/shop'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://fisher.globat.com/~anbeadsjewelry.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL',true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.anbeadsjewelry.com/shop');

define('HTTPS_COOKIE_DOMAIN', 'https://fisher.globat.com/~anbeadsjewelry.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/shop/');

define('DIR_WS_HTTPS_CATALOG', '/shop/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/usr/local/psa/home/vhosts/anbeadsjewelry.com/httpdocs/shop/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'xxx');

define('DB_SERVER_PASSWORD', 'xxx');

define('DB_DATABASE', 'xxx');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

Sometimes you're the dog and sometimes the lamp post

[/url]

My Contributions

Link to comment
Share on other sites

Try this one, worth pointing out that your SSL was set incorrectly + when i went to your SSL site the images were there.

Have they cached your site on the server or you uploaded it to there?

Back up first please!

 

<?php

/*

osCommerce, Open Source E-Commerce Solutions

http://www.oscommerce.com

 

Copyright © 2003 osCommerce

 

Released under the GNU General Public License

*/

 

// Define the webserver and path parameters

// * DIR_FS_* = Filesystem directories (local/physical)

// * DIR_WS_* = Webserver directories (virtual/URL)

define('HTTP_SERVER', 'http://www.anbeadsjewelry.com/shop'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://fisher.globat.com/~anbeadsjewelry.com'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL',true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'www.anbeadsjewelry.com/shop');

define('HTTPS_COOKIE_DOMAIN', 'https://fisher.globat.com/~anbeadsjewelry.com');

define('HTTP_COOKIE_PATH', '/');

define('HTTPS_COOKIE_PATH', '/');

define('DIR_WS_HTTP_CATALOG', '/shop/');

define('DIR_WS_HTTPS_CATALOG', '/shop/');

define('DIR_WS_IMAGES', 'images/');

define('DIR_WS_ICONS', DIR_WS_IMAGES . 'icons/');

define('DIR_WS_INCLUDES', 'includes/');

define('DIR_WS_BOXES', DIR_WS_INCLUDES . 'boxes/');

define('DIR_WS_FUNCTIONS', DIR_WS_INCLUDES . 'functions/');

define('DIR_WS_CLASSES', DIR_WS_INCLUDES . 'classes/');

define('DIR_WS_MODULES', DIR_WS_INCLUDES . 'modules/');

define('DIR_WS_LANGUAGES', DIR_WS_INCLUDES . 'languages/');

 

define('DIR_WS_DOWNLOAD_PUBLIC', 'pub/');

define('DIR_FS_CATALOG', '/usr/local/psa/home/vhosts/anbeadsjewelry.com/httpdocs/shop/');

define('DIR_FS_DOWNLOAD', DIR_FS_CATALOG . 'download/');

define('DIR_FS_DOWNLOAD_PUBLIC', DIR_FS_CATALOG . 'pub/');

 

// define our database connection

define('DB_SERVER', 'localhost'); // eg, localhost - should not be empty for productive servers

define('DB_SERVER_USERNAME', 'xxx');

define('DB_SERVER_PASSWORD', 'xxx');

define('DB_DATABASE', 'xxx');

define('USE_PCONNECT', 'false'); // use persistent connections?

define('STORE_SESSIONS', ''); // leave empty '' for default handler or set to 'mysql'

?>

 

You are great to keep trying to figure this out for me!

 

I tried to upload the copy you just gave me. The header has gone from the shopping cart, but now I'm getting an Unable to connect to database server! message on the login and checkout pages. Any thoughts?

Link to comment
Share on other sites

Check the configure.php on your admin side it may be wrong there too

 

 

I can only find one configure.php- in the /includes folder. It's the one I sent you. Am I missing something?

Link to comment
Share on other sites

I can only find one configure.php- in the /includes folder. It's the one I sent you. Am I missing something?

 

ok- I must be a true dolt with this. I found another configure.php file in admin/includes/configure.php. What must I change to get this to work?

Link to comment
Share on other sites

The details from your includes configure.php change the details to felect the changes you made in the one previously.

Only the ones that look similar tho, there are different settings in the admin one.

ok, I don't know how or why, but I got rid of the error message. All I did was upload a copy of the shop/includes/configure.php again, and everything went back to the way it was.

 

Now I still have the same problem: How do I get rid of the oscommerce logos from my login and checkout pages, and how do I make the left and right columns contain the same boxes and photos that the front pages have? Any ideas?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...