Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Authorize.net


gdh

Recommended Posts

I have set up the A-net account and configured it in the store - yet it doesn't show up as a payment option!

 

I have another store created last year which works fine...though I noticed the new store has several more payment options than the older one...I assume they must be a different version of Oscommerce, though if so I can't seem to find any indication of it.

 

Any help or guidance is appreciated.

Link to comment
Share on other sites

Yes sir...settings as follows:

 

Enable Authorize.net Credit Card AIM

true

 

Login ID & Login ID

as per A-net

 

MD5 Hash

set

 

Transaction Server

live

 

Transaction Mode

live

 

Transaction Method

authorization

 

 

 

I'm confused as to why it isn't showing up!!

Link to comment
Share on other sites

Hmmm - I don't recognise those settings. These are the ones associated with the standard AIM module:

 

Enable Authorize.net AIM Module

True

 

Login Username

xxxx

 

Transaction Key

xxxx

 

Transaction Mode

Live

 

Authorization Type

Authorize/Capture

 

Customer Notifications

False

 

Merchant Notifications

True

 

Request CVV Number

True

 

Sort order of display.

0

 

Payment Zone

--none--

 

Set Order Status

default

 

Not sure why it's not showing up - the modules that display are taken from the php files present in the /includes/modules/ directory. Maybe remove your A.net files and install this:

 

http://www.oscommerce.com/community/contributions,4091

Link to comment
Share on other sites

I just intalled the contrib mentioned...didn't change a thing!

 

modules/payment includes the following A-net files:

 

authorizenet.php (there at the initial install)

authorizenet_aim.php (added by above contrib)

authorizenet_cc_aim.php (there at the initial install)

authorizenet_cc_sim.php (there at the initial install)

 

In my older store...which was only in November...only the authorizenet.php file is present.

 

Your assistance is appreciated sir.

Link to comment
Share on other sites

Thanks for your help Jason. The module is showing up now...reinstalled the contrib. Apparently the authorize.net credit card AIM module included in the osc basic install is something different than the authorize.net AIM module...I was getting confused (lol).

 

Hopefully everything will work now.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...