Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

uploaded files


hanbar

Recommended Posts

Help

 

I wanted to comment out the header.php from the product_info and advanced_search files. I used text that looked like this:

 

php //require header.php

 

(the important part is the 2 backslashes)

 

When I tested the pages on my website, both the product page and the advanced search page had vanished.

 

To correct the problem tried to delete the backslashes, and I tried to upload a copies of the original files, from my computer. Both attempts produced an error message on my website that read:

 

The script /usr/local/psa/home/vhosts/anbeadsjewelry.com/httpdocs/shop/product_info.php cannot be world writable.

 

Does anyone know why this happened? Does anyone know how I can fix it?

 

Thanks so much- I'm very frustrasted.

 

Hannah

Link to comment
Share on other sites

The permissions on the uploaded file are insecure.

 

Use the facilities that should be in your ISPs admin area to change the permissions on product_info.php.

 

(See what the others are set to, your ISP help desk should be able to help you with file permissions)

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Link to comment
Share on other sites

Thanks- I tried what you said: their were 2 different permissions for all the files that I have- 644 and 755. I changed the permissions on the 2 files that I was working on, and nothing happened. I still get the same error message.

 

I'm open to suggestions. What else can I try?

 

Hannah

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...