Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Stylesheet.CSS in admin ... appears to not be seen


fmcleod@comcast.net

Recommended Posts

I have installed osCommerce on my development PC in my office ... all works like a charm after fixing some configure.php issues. All buttons, icons, formatting, etc. works fine. I moved it to a hosted service (Startlogic.com) and all of the catalog area works great. However, when I go to admin, I get funky text formatting without the stylesheet.css being seen.

 

I have combed every reference I can online ... just for grins (Yes, I know it is dangerous, but I did it to see if it would shake anything loose ... I changed all permissions to 777 planning to reverse that later). That did not help. I tried putting the stylesheet.css in the same directory with login.php and index.php ... that did not help. I eliminated the .htaccess file as I read that some others have done ... that did not help.

 

In login.php, the location of stylesheet.css is hard-coded as includes/stylesheet.css. From the directory in which login.php is located, that is the correct path. I even tried to hard-code the path with my full domain path, "http://mydomain/oscommerc/catalog/admin/includes/stylesheet.css" and that had no affect. HELP!

 

If you can help, please do. I am stymied with proceeding in admin until I get this simple (but frustrating) problem resolved.

 

Thanks in advance if you can help.

Frank

Link to comment
Share on other sites

Okay ... posting this was not very helpful ... no one responded. However, in the meantime, I did some investigating. In case someone is struggling with the same problem, I share what I have discovered after a lot of time spent and heartburn. Every post I saw where someone was having a similar problem, to try to help everyone wanted to jump on the syntax, the paths, configure.php, etc. I heard people, such as me, keep moaning, "I've done all that and still have the problem."

 

Where there were some problem areas, such as Stylesheet.css not being picked up, I tried to go to it directly in my browser ... and voila' ... I got an access denied error. This did not happen on my home PC, so it had me baffled ... it only happened when I ported everything to my hosting service (and it only happened on certain folders ... doing CHMOD had no affect).

 

What clued me in was that a page intervened from a service called IISPassword ...which obviously is a service used by Startlogic.com. What it does on a Windows server is determine if .htaccess exists in a folder ... if it does (EVEN IF ALL OF ITS CONTENTS ARE COMMENTED OUT!), it denies access. I removed the useless .htaccess (for my Windows server) from the folder and Stylesheet.css was seen, and all is cool.

 

In the many posts I have seen, some have complained about some of the buttons in the same manner. For example, the inludes/languages/english/images/buttons was not being accessed ... same problem ... .htaccess was restricting it on my Windows hosted service.

 

Hope this helps someone else ... I wasted a full three days on this issue.

 

Frank

Link to comment
Share on other sites

  • 2 weeks later...

Ok, but what if you need the .htaccess? I have exact the same problem but I am on Apache - Linux. I spend a lot of time to bring it to work but no success so far. I did some test and copied the stylesheet.css "down the folder" and changed link in the files to <link rel="stylesheet" type="text/css" href="stylesheet.css"> and it works. Even if in this folder is also .htaccess file. Is that the server issue or ??? I do not have to much knowledge about .htaccess files.

 

Andrew

Link to comment
Share on other sites

  • 9 months later...

Worked fine for me. I deleted .htaccess from catalog/ catalog/includes catalog/admin and catalog/admin/includes and voila.. all problems with unaccessible images/css sheets gone for good. Thanks for posting. I do not know what works for apache but it could be the same issue just with another workaround

 

Matus

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...