Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.



Recommended Posts

Well, it was working before I had to "update"... Anyway, I know very little about PHP (although I love to learn, and I'm learning alot...) and the shop seems to want to crap in my cornflakes...


Anyway, I love osCommerce. I just have to learn all of this stuff.


If anyone can help me out on why authorize.net isn't working (anymore) with the new release I'd appreciate your comments.


I'm the one that sank my last osCommerce a couple of days ago. I salvaged that database but with all of the database incompatibilities between the original 2.2 to Nov, it's not worth the trouble of deleting duplicate/rogue fields...


Anyway, I've got the standard setup going on at www.cookssaw.com/shop/default.php


1054 - Unknown column 'customers_company' in 'field list'


insert into orders (customers_id, customers_name, customers_company, customers_street_address, customers_suburb, customers_city, customers_postcode, customers_state, customers_country, customers_telephone, customers_email_address, customers_address_format_id, delivery_name, delivery_company, delivery_street_address, delivery_suburb, delivery_city, delivery_postcode, delivery_state, delivery_country, delivery_address_format_id, billing_name, billing_company, billing_street_address, billing_suburb, billing_city, billing_postcode, billing_state, billing_country, billing_address_format_id, payment_method, cc_type, cc_owner, cc_number, cc_expires, date_purchased, orders_status, comments, currency, currency_value) values ('2', 'Brandon Holland', '', '160 Ken Lane', '', 'Newton', '36352', 'Alabama', 'United States', '3346925074', 'brandon@cookssaw.com', '2', 'Brandon Holland', '', '160 Ken Lane', '', 'Newton', '36352', 'Alabama', 'United States', '2', 'Brandon Holland', '', '160 Ken Lane', '', 'Newton', '36352', 'Alabama', 'United States', '2', 'Authorize.net', '', '', '', '', now(), '1', '', 'USD', '1.00000000')



- - - -

Sometimes, ignorance is bliss.

Link to comment
Share on other sites

If I comment out ALL the fields it doesn't know about (all of the billing_* fields and the *_company fields) I can process a money order/check.


Anyone know what's going on with my wacky cart?


Thanks for your time.

- - - -

Sometimes, ignorance is bliss.

Link to comment
Share on other sites

It's not just in authorize.net


I tried COD and still get the error...


Anyone get any ideas?




The newer snapshots have fields that are added/changed/deleted from older ones, the 'customers_company' is one of them. It's basically trying to add in a value for that field to a table that doesn't have it available.


I'd try and figure out a way to export your data, do a complete clean and install, and then reimport the data that fits.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...