Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Session key and mysql max_questions exceeded


eyeconect

Recommended Posts

Been searching for answer to problem i am starting to have,

 

"

1226 - User 'larryjor_store' has exceeded the 'max_questions' resource (current value: 50000)

 

select value from jor_sessions where sesskey = '2a5441ad8be39ea25d2d95dbc4f4d74f' and expiry > '1203091695'

 

[TEP STOP]

 

"

 

Any idea what is causing this and how to fix this....

 

I think my osC is being hammered by spammers ...

 

Any clue will be appretiated.

 

Thanks

Link to comment
Share on other sites

Thats usually set by your ISP - it may be spammers or it may be legit. Depending on how many users and what contributions you are running - keep in mind that osc uses the db fairly heavily.

Even at a Mensa convention someone is the dumbest person in the room.

Link to comment
Share on other sites

Make sure that the last line of both configure.php files says 'mysql' where indicated, thus storing sessions in the database and not in files in a temp folder. MySQL has a "garbage clean up" routine which removes dead sessions after 23 minutes of inactivity, whereas sessions stored in files will just continue to build up and up until they use up your web hosting allowance. If MySQL is not correctly deleting them then you can always select the 'sessions' table in phpMyAdmin and elect to 'truncate' the table - which means emptying out all stored sessions.

 

In osC admin set "Show category counts" to false, and make sure that your site does not check "Page parse times". Both will use up valuable mysql queries.

 

Read the thread called "A store speed optimisation in progress" for tips on cutting out unnecessary sql queries.

 

Vger

Link to comment
Share on other sites

  • 2 weeks later...

After attending to all aspects of sql sessions check as suggested by vger..Thanks vger. Found that db is clean... session table was reasonable size, tables are not hacked into and destroyed etc.. The site has always used mysql to store sessions.

 

I think , spammers are at it... because global resource set by my isp was being triggerd. It is possible my isp is having configuration issues, of course they will not tell me they are having problems, but they do restart mysql when we complain.

 

 

I did turn on , check referer for session. in classes/sessions.php . This seems to have reduced the amount of time I would get max questions exceeded .

This should be a necessary check for setting any session. As it somewhat guarantees surfur/browser interaction with the store and not a bot.

 

 

Regards.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...