Jump to content
  • Checkout
  • Login
  • Get in touch


The e-commerce.

I know, I know. Error 1054 causing problems.


Recommended Posts

First off I will say that I have searched the forums for this one, but most people do not reply. For those people who do post, and figure it out themselves, they say 'thanks anyways' and do not include what they did to fix the problem. If this error actually has a resolution in the forums somewhere, I'm sorry I missed it.


I recently reinstalled the newest version of osC, but I did a databse backup from my database when using v2.?. I am now getting this error. I was getting an error about 'Table 'orders_total' does not exist, so I created it with all of the fields I was told I needed. The first field being 'orders_id' and now I recieve this error when trying to complete an order.


This is occuring when you go to shop/checkout_process.php


1054 - Unknown column 'orders_id' in 'field list'


insert into orders_total (orders_id, title, text, value, class, sort_order) values ('5', 'Sub-Total:', '$159.99', '159.99', 'ot_subtotal', '1')




Thanks everyone,


Chris Sullivan

Link to comment
Share on other sites

Someone answered me a while back about this. I had the same problem. Anyway, as you know it's a difference between the database fields of the versions.


To tell you the truth man, I gave up hope on straightening it out...


It's too big of a deal if you don't have a huge inventory...


If you do want to try it out maybe you can add the fields that don't exist with phpmyadmin, and remove those that aren't needed anymore (Or comment them out in the checkout_process.php


I commented the fields it don't know about in checkout and it would let me process orders, but i was still having an authorize.net problem, (which by the way I STILL HAVE) and started over.


Just curious, do you have "duplicate" fields in your admin configuration? I did. One was for the older db and one for the newer...

- - - -

Sometimes, ignorance is bliss.

Link to comment
Share on other sites

I just blew away all the tables having anything to do with orders, and I went and downloaded the most current snapshot. From there I ran an sql query that created all of the new tables relating to the orders tables.




Worked no problem.

Thanks for the help,


Chris Sullivan

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...