Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Warning: 644 error


bluwave

Recommended Posts

Warning: I am able to write to the configuration file: /home/fhlinux153/b/bluwave.co.uk/user/htdocs/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

 

thats the msg i get

 

the file CHMOD is 644

 

all other file permissions have been set as advised by installation guide.

 

is this message returned to me because somehow the script knows i am the author and can write to the file?

 

very strange.. ive not had this on previous installs of osc

Link to comment
Share on other sites

Think you should read all of the post installation documentation.

 

http://www.oscommerce.info/kb/osCommerce/I...nd_Upgrades/224

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Link to comment
Share on other sites

Think you should read all of the post installation documentation.

 

http://www.oscommerce.info/kb/osCommerce/I...nd_Upgrades/224

 

not quite sure what your trying to say, i did read the instructions.

 

the instructions say:

Reset the permissions on catalog/includes/configure.php to 644 (if you are still getting the warning message at the top of the page after setting this configure.php files to 644 then set the catalog/includes/configure.php file to 444 which is read only - this happens on some servers that have been updated for security reasons).

 

 

and i say:

i have done this, i get the same message whether its changed to 644 or 444.. which was why i needed help in trying to get to the bottom of the problem

 

i also said all the other permissions have also been set as advised in the installation instructions, by that i mean:

3. Set the permissions on catalog/images directory to 777

4. Set the permissions on admin/images/graphs directory to 777

5. Create the directory admin/backups and set the permissions to 777

 

but thanks anyway

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...