Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

config.php wont upload?


darren713

Recommended Posts

I'm thinking if the file on the server is set to Read Only (444) Dreamweaver may not overwrite it. Try a FTP program or your hosts file manager to upload it.

Installed Contributions: CCGV, Close Popup, Dynamic Meta Tags, Easy Populate, Froogle Data Feeder, Google Position, Infobox Header Entire Row, Live Support for OSC, PayPal Seal with CC images, Report_m Sales, Shop by Price Revised, SQL Updater, Who's Online Enhancement, Footer, GNA EP Assistant and still going.

Link to comment
Share on other sites

I'm thinking if the file on the server is set to Read Only (444) Dreamweaver may not overwrite it. Try a FTP program or your hosts file manager to upload it.

 

What would you suggest? for a good ftp program and would it contradict dreamweaver in uploading the rest of the pages? i guess what i am trying to say is can i use dreamweaver and another ftp program for one site? also do i need to set the file to (755) because the problem i have with DW i cant get into the directory to change the .CGI to (744) rather than (444).

Link to comment
Share on other sites

I have made a file in file manager (cpanel) and copied everything from the compat file from DW into the new file i made in file manager., However i still get the same error?

 

Warning: require(includes/functions/compatibility.php) [function.require]: failed to open stream: No such file or directory in /home/liz/public_html/catalog/includes/application_top.php on line 40

 

Fatal error: require() [function.require]: Failed opening required 'includes/functions/compatibility.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/liz/public_html/catalog/includes/application_top.php on line 40

 

Would you know why that is?

Link to comment
Share on other sites

Hi, I believe what require(includes/functions/compatibility.php) file does not exist means is that it cannot find the file campitibility.php at all under includes/functions. Are you sure that you have this file uploaded to the right folder?

 

I like to use an ftp program to upload my files after I have changed them. I use smart ftp, but there are several other free ones that you can download that work well. I have read that you shouldn't use your admin panel to upload files for some reason.

 

Anyway, recheck your includes/functions folder to verify that the compatibility.php file is there.

Link to comment
Share on other sites

thanks for all of your answers, i will try using smartFTP, but just a quickie, will that affect the way i use DW? or do i drag and drop all of the files from my directory to the SmartFTP? as on dreamweaver it is saying i do not have permission to upload the functions folder which obviously has all the necessities i need.

Link to comment
Share on other sites

well i deleted all the folders i uploaded via DW and installed SmartFTP and uploaded them via that program now and it seems i have sorted the compatibility.php problem out only to get replaced with a new problem below??? now i am confused

Link to comment
Share on other sites

Warning: require(includes/application_top.php) [function.require]: failed to open stream: No such file or directory in /home/liz/public_html/catalog/account.php on line 13

 

Fatal error: require() [function.require]: Failed opening required 'includes/application_top.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/liz/public_html/catalog/account.php on line 13

 

(it would have probably helped if included it :lol: :lol: )

 

Also i cannot upload my database connection via smartftp or DW? it says file transfer failed use the transfer queue but to no avail? so i cannot access the login page or anything. This is driving me insane. Sorry for all these probs guys

Link to comment
Share on other sites

Hi, I am not sure if this is going to be the answer to all, but I just read in a different post that:

 

According to those with a lot of osC experience:

 

Folder permissions should be 755, and files should be 644

 

 

Then the respondent posted back:

Yes, thats it. I took me 45 minutes but now all the files/folders have the right settings and there are no more error messages.

 

Try putting the correct permissions on the folders and files and see if that helps you as well.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...