Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Division by 0?


Guest

Recommended Posts

I've seen a lot of errors in my years with oscommerce, but this one takes the cake! My wife attempted to do a back-up after making some changes in the catalog, and of course the cart crashed. Then, our illustrious web host, ipower, got involved and totally killed it! Here's the error I'm getting:

Warning: Division by zero in /home/mysticea/public_html/includes/classes/split_page_results.php on line 59

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'MAX_DISPLAY_SEARCH_RESULTS' at line 1

Ipower says it's a code issue that they can't fix, (strange since they're the ones that caused it), and now I'm left with nothing. The entire catalog of over 3000 products is gone, as well as the customer database of over 200 customers. Can anyone help?

Thanks!

Ron

Link to comment
Share on other sites

I've seen a lot of errors in my years with oscommerce, but this one takes the cake! My wife attempted to do a back-up after making some changes in the catalog, and of course the cart crashed. Then, our illustrious web host, ipower, got involved and totally killed it! Here's the error I'm getting:

Warning: Division by zero in /home/mysticea/public_html/includes/classes/split_page_results.php on line 59

1064 - You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'MAX_DISPLAY_SEARCH_RESULTS' at line 1

Ipower says it's a code issue that they can't fix, (strange since they're the ones that caused it), and now I'm left with nothing. The entire catalog of over 3000 products is gone, as well as the customer database of over 200 customers. Can anyone help?

Thanks!

Ron

 

Try checking your admin - configuration - maximum values and looking at the value in Search Results. Perhaps it's set to 0? That would cause that sort of thing.

 

Ed

Link to comment
Share on other sites

As mentioned above, a possible solution to some of these problems is to check your values in the "Maximum Values" area of the Admin - Configuration panel.

 

I was getting a "divide by zero" error on the account_history page, and I checked the Configurations settings, and the Order History was set to 0. I changed it to 10, and that got rid of that error.

 

So if you are experiencing any of these errors, particularly a "divide by zero" error, try going to Admin > Configuration > Maximum values, and see if the value associated with the trouble you are having is set to 0. Try setting it to something else and see if that clears up the problem.

Link to comment
Share on other sites

Exact same error here:

 

Click Me

 

(Resolved)

If I suggest you edit any file(s) make a backup first - I'm not perfect and neither are you.

 

"Given enough impetus a parallelogramatically shaped projectile can egress a circular orifice."

- Me -

 

"Headers already sent" - The definitive help

 

"Cannot redeclare ..." - How to find/fix it

 

SSL Implementation Help

 

Like this post? "Like" it again over there >

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...