Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

MYSQL Connect Warning, please help


kevinb84

Recommended Posts

Hey all,

 

I was trying to figure out what went wrong.. Today all of a sudden my store tells me that the includes/configure.php file can be written on and that I should change it. so of course I attempt to change the attributes but it would not let me change to 444 like the manual says. Everytime I tried it would go right back to 644. So I reuploaded the file and poof... I get this error.

 

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'babypris'@'localhost' (using password: NO) in /home/babypris/public_html/catalog/includes/functions/database.php on line 19

Unable to connect to database server!

 

I don't even know where to begin. I looked and the file I replaced it with is exactly the same so idk what would have caused this. If someone could help this would be great as I JUST finshed the site, was looking it over for any mistakes when I saw that original error message.

 

Thanks all,

-Kevin

Link to comment
Share on other sites

During setup the configure.php is actually set up with certain information, i.e. username and password for the database. Since you presumable overwrote the version on the server with a vanilla version of that file, you'll either have to find a backup copy of the version you overwrote or fill in the blanks yourself. The error message tells you that its trying to connect without the password which doesn't usually work.

 

The initial problem: setting the file to 444 doesn't work on all systems - 644 is the next best choice and just fine.

Even at a Mensa convention someone is the dumbest person in the room.

Link to comment
Share on other sites

During setup the configure.php is actually set up with certain information, i.e. username and password for the database. Since you presumable overwrote the version on the server with a vanilla version of that file, you'll either have to find a backup copy of the version you overwrote or fill in the blanks yourself. The error message tells you that its trying to connect without the password which doesn't usually work.

 

The initial problem: setting the file to 444 doesn't work on all systems - 644 is the next best choice and just fine.

 

Thanks for the reply but I'm still not sure what to do.. You said to reupload it with a backed up copy which I tried doing immediately afterwards to no avail. Would I be able to edit the file?

 

Also the file was originally set to 644 which confused the heck out of me because 644 is where only YOU can overwrite but I was still getting that message. Thats why I tried 444 but it didn't work anyway.

Link to comment
Share on other sites

Thanks for the reply but I'm still not sure what to do.. You said to reupload it with a backed up copy which I tried doing immediately afterwards to no avail. Would I be able to edit the file?

 

Also the file was originally set to 644 which confused the heck out of me because 644 is where only YOU can overwrite but I was still getting that message. Thats why I tried 444 but it didn't work anyway.

Are you using your webhosts control panel filemanager to set the permissions?

Link to comment
Share on other sites

No, I was using my FTP but that was not an issue when installing the store originally.

So do I, using filezilla. However, what I posted was the final fallback position before you ask your webhost to do it.

Link to comment
Share on other sites

So do I, using filezilla. However, what I posted was the final fallback position before you ask your webhost to do it.

 

I'll try it once/if I get my store back up... still not sure why I'm getting this error but hopefully i can get it sorted out

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...