Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Returning to site after payment


Guest

Recommended Posts

Hi there,

 

When a customer goes through the shopping cart all appears to be working okay. :)

If they click on paypal they get directed to paypal with no problems where they make the payment - okay. :)

 

Once completed, when the click on Return to Merchant, they arrive back at a blank screen which should be checkout_process.php. They do not get an email from my store, neither do I and their cart retains the items. :(

 

The order does show up in my admin section though.

 

I also have a bank transfer module installed, along with a cheque payment module. When you select either of these as an option it returns you to a blank screen that should be checkout_confirmation.php - not giving the customer the details to send the payment to. :'(

 

I am a newbie to oscommerce, and would appreciate a fool proof answer - as i am on a steep learning curve!! :blink:

 

Thanks in advance

 

Gav

Link to comment
Share on other sites

Hi there,

 

When a customer goes through the shopping cart all appears to be working okay. :)

If they click on paypal they get directed to paypal with no problems where they make the payment - okay. :)

 

Once completed, when the click on Return to Merchant, they arrive back at a blank screen which should be checkout_process.php. They do not get an email from my store, neither do I and their cart retains the items. :(

 

The order does show up in my admin section though.

 

I also have a bank transfer module installed, along with a cheque payment module. When you select either of these as an option it returns you to a blank screen that should be checkout_confirmation.php - not giving the customer the details to send the payment to. :'(

 

I am a newbie to oscommerce, and would appreciate a fool proof answer - as i am on a steep learning curve!! :blink:

 

Thanks in advance

 

Gav

What addons have you installed or is it a template?

Link to comment
Share on other sites

What addons have you installed or is it a template?

 

Thanks for your speedy response, my business is ready to roll, all products are on shop ready, just need to sort this issue

Please excuse my total lack of knowledge:

 

I am using XOOPS version 2.0.16

X-Osc Version 0.73 - OSCommerce MS2.2 for XOOPS

 

The checkout_confirmation OR process.php 's weren't working when i first installed - if i remember correctly

 

The payment additions that i added were:

 

Bank Transfer Payment Contribution_1c

and

Cheque Module 1.0.0 (leigh Davies 2003)

 

Hope this helps!!

Gav

Link to comment
Share on other sites

  • 3 weeks later...
For X-Osc Version 0.73 - OSCommerce MS2.2 for XOOPS, the XOOPS forum would be the place to ask.

thanks for your help on this:

 

i found that for some reason i was getting alot of problems trying to integrate within xoops - plus a mate of mine was building part of the site and i was building another. Got a bit of a mess!! So i decided to go on a steep learning curve and built an all new store/catalogue with oscommerce. Looks good and i'm proud to say that i managed to build it on my own - even though i'm a complete beginner ;) (www.wwgiftware.co.uk)

 

Payment methods working fine in this - my old site must have been corrupt.

 

Thanks again

 

Gav

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...