Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Cart does not empty


manu011

Recommended Posts

Hi,

 

After a client log in and purchase, my bank accept payment. Ok.

But any order appears in Admin, and any mail with the order is send (to client, to the store (config in Admin)).

The client's cart does not get empty, is still with the products order.

 

Some days before, all worked well, after purchase the cart was empty and the order was generated and the mails were send.

 

 

What can i do?

 

Thks

Link to comment
Share on other sites

Manu

 

Just to clarify, when a customer checks out

 

1. The bank takes a payment

 

2. The customer gets an order acknowledgement email

 

3. The shop gets an email

 

4. The customer's cart still contains the products they have just ordered.

Need help installing add ons/contributions, cleaning a hacked site or a bespoke development, check my profile

 

Virus Threat Scanner

My Contributions

Basic install answers.

Click here for Contributions / Add Ons.

UK your site.

Site Move.

Basic design info.

 

For links mentioned in old answers that are no longer here follow this link Useful Threads.

 

If this post was useful, click the Like This button over there ======>>>>>.

Link to comment
Share on other sites

Clarifying:

 

1. The bank takes a payment (YES)

 

2. The customer DOESNT get an order acknowledgement email

 

3. The shop DOESNT get an email

 

4. The customer's cart still contains the products they have just ordered (YES).

 

 

 

I think the problem is that purchase "doesnt end", then cart still intact, emails arent send and order isnt created.

I dont know how to fix this trouble. Couriosly, a week away all worked well.

 

Thks again

Link to comment
Share on other sites

Clarifying:

 

1. The bank takes a payment (YES)

 

2. The customer DOESNT get an order acknowledgement email

 

3. The shop DOESNT get an email

 

4. The customer's cart still contains the products they have just ordered (YES).

I think the problem is that purchase "doesnt end", then cart still intact, emails arent send and order isnt created.

I dont know how to fix this trouble. Couriosly, a week away all worked well.

 

Thks again

Time to examine the installation of your bank payment module (if nothing else is touched). Install one of the default payment options such as check/money order and see it the process works.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...