Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Images on ass SSL pages have disappeared


bw92116

Recommended Posts

Sorry, I meant to type "Images on all SSL pages have disappeared."

 

I use a shared SSL certificate from my host provider, and my product pages are on an http:// server, while the login, create account, checkout, admin, etc. all appear as https:// pages. Up until today everything was working fine. Suddenly today, images on https:// pages are not showing up any more - all images on all of those pages are missing. All the product pages, category pages and the main store are all fine- all images show up. Those are all http://. What could be wrong? The relevant lines of the 2 configure.php files are shown here. But they are unchanged - previously it worked with all of these settings. What could be causing all images on any page with https:// to be missing?

Thanks for your help!

 

includes/configure.php

 

define('HTTP_SERVER', 'http://fireworksland.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTPS_SERVER', 'https://gator161.hostgator.com/~rjweaver'); // eg, https://localhost - should not be empty for productive servers

define('ENABLE_SSL', true); // secure webserver for checkout procedure?

define('HTTP_COOKIE_DOMAIN', 'fireworksland.com');

define('HTTPS_COOKIE_DOMAIN', 'gator161.hostgator.com/~rjweaver');

define('HTTP_COOKIE_PATH', '/osc/');

define('HTTPS_COOKIE_PATH', '/osc/');

define('DIR_WS_HTTP_CATALOG', '/osc/');

define('DIR_WS_HTTPS_CATALOG', '/osc/');

define('DIR_WS_IMAGES', 'images/');

 

 

admin/includes/configure.php

 

define('HTTP_SERVER', 'http://fireworksland.com'); // eg, http://localhost - should not be empty for productive servers

define('HTTP_CATALOG_SERVER', 'http://fireworksland.com');

define('HTTPS_CATALOG_SERVER', 'https://gator161.hostgator.com/~rjweaver');

define('ENABLE_SSL_CATALOG', 'true'); // secure webserver for catalog module

define('DIR_FS_DOCUMENT_ROOT', '/home/rjweaver/public_html/osc/'); // where the pages are located on the server

define('DIR_WS_ADMIN', '/osc/admin/'); // absolute path required

define('DIR_FS_ADMIN', '/home/rjweaver/public_html/osc/admin/'); // absolute pate required

define('DIR_WS_CATALOG', '/osc/'); // absolute path required

define('DIR_FS_CATALOG', '/home/rjweaver/public_html/osc/'); // absolute path required

define('DIR_WS_IMAGES', 'images/');

Link to comment
Share on other sites

I figured it out. I had enabled "Hotlink Protection" on my account, and that was causing the https:// pages to be treated as a different web site, so they were not allowed access to the images. To fix this, I added the https:// path to the list of URLs allowed access to the images. Now they images show up on the https:// pages. So if anyone else is having this problem, check your Hotlink Protection settings in addition to your permissions.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...