Jump to content
  • Checkout
  • Login
  • Get in touch

osCommerce

The e-commerce.

Can't Delete Backup from Admin...


Guest

Recommended Posts

Hi, I'm having a little problem, Everything is working ok, I can backup and all... But then when I tried to delete my older backup, it say it cannot delete. When I ftp, I found out that the backup file written is in CHMOD 644, where by I tried putting the backup directory on CHMOD 777 but when I backup and check the new file, it's back to CHMOD 644... Why is it doing this? Does anyone have any ideas? Thanks

Link to comment
Share on other sites

Probably a misconfiguration issue with your apache....

 

Usually when you backup with the backup tool....your backup files are backed up not under the username that you use to upload you files but its under whatever apache uses and in most cases its a user called apache.....

 

I think the only way you can fix this is to add your username to the apache group or add apache to your user group.....but as a temp fix you can always delete the files as root.

 

However what I dont understand is why are you not able to delete the backup files from the backup tool itself...because technically apache should be able to delete the files it created.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...